2

My external HD got unplugged without ejecting and my Mac will no longer mount the drive, but it recognizes it's there.

I already tried repairing the disk in Disk Utility, and erasing it in Disk Utility, and it still won't mount. I can't imagine the hardware is actually damaged otherwise it wouldn't even recognize it (Right?).

Is there any other software solution I can try? Recovering my files is not a concern.

2
  • Try apple.stackexchange.com – Paul R Aug 5 '11 at 21:08
  • 2
    @slhck The comment was added before it was actually migrated here from Stack Overflow, so I guess it's fair. – Gaff Aug 6 '11 at 5:01
0

Open a Terminal and type mount to see what disks are mounted to your Mac OS

jontsai@machine:~$ mount
/dev/disk0s2 on / (hfs, local, journaled)
devfs on /dev (devfs, local)
fdesc on /dev (fdesc, union)
**/dev/disk1s1 on /Volumes/JONTSAI_USB (msdos, local, nodev, nosuid, noowners)**

The last one is my USB flash drive. If you didn't eject it, the OS might still think that it's mounted, so you will need to manually unmount it.

Use the umount command

umount /dev/disk1s1

I would do that to unmount my USB flash drive, but you should use whichever line represents your external HDD.

If all else fails, try rebooting to see if it fixes itself.

1
  • this is a long term problem. This hard drive has been broken for a few months. Its not that it unmounts, its that it won't mount to begin with. In full disclosure I also tried reformatting it with ubuntu's version of disk utility (still called disk utility i think) – Sam Bryant Aug 5 '11 at 22:51
0

This can be caused by fsck_hfs running in the background for no good reason. Maybe left over from an attempt to run First-Aid? In any event: start Activity Monitor and have a look for fsck_hfs. It was taking 35% of my CPU when I looked. I simply Force-Quit the process. OSX mounted the drive and started TimeMachine instantly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.