12

I have a Mac Pro and a 120 Mbps up (2 Mbps down) broadband cable connection over my Fritbox 7390.

When I use the Microsoft RDP Client or the CorD-Client on OS X (Lion, Snow Leopard, Leopard - all have the same problem), the RDP connection is very slow. When I start Windows in Boot Camp on the same machine and use the RDP client from Windows, everything is fine.

Can anyone tell me the reason for this? How can I fix it? Are there any modifications I can make, such as TCP optimization?

2
  • The RDS protocol has various optimisations in it, not all of which a client is required to implement. They get added over time. Obviously Microsoft's client implements most of them, the only other client I've seen that implements a lot of them is iTap. But it's commercial (although it was worth it for me, for near to mstsc performance). If you can compile FreeRDP (good luck!), I hear it performs well too. Apr 26 '13 at 21:51
  • Have Parallels? Try running RDP that way?
    – Keltari
    Dec 30 '14 at 0:22
6

I don't know for sure, but I've heard the same complaint. A theory is that on Mac (and Linux) the full images are sent over the network, whereas on Windows some higher level drawing commands are sent, at least for some parts of the screen.

It'd be interesting to try running Remote Desktop Client for Windows on the Mac (or Linux) using Wine, and compare performance this way.

1
  • this should not be the case with modern implementations.
    – AndreLung
    Jul 15 '20 at 11:19
5

I had this problem on my MacBook Pro with this:

sudo -s
sysctl net.inet.tcp.delayed_ack=0

To make it stick between reboots, add it to /etc/sysctl.conf with…

echo net.inet.tcp.delayed_ack=0 >> /etc/sysctl.conf
1
  • 2
    Why is this working and how did you find out?
    – AndreLung
    Jul 15 '20 at 11:18
2

I had this very issue but the interesting thing is that the RDC to this machine had been working fine some days before – but all of a sudden, over a gigabit network I could see each bitmap block coming across. I tried some other solutions such as executing:

netsh interface tcp set global rss=disabled
netsh interface tcp set global autotuninglevel=disabled

from an elevated commas prompt as suggested here: Vista Remote Desktop Connection Client Slow Delay or Disconnect When Connect to Windows Server 2003 SP2 x64 Edition RDP. That didn't work though.

Then I twigged what had changed since it last worked. I had re-enabled by realtime virus checker (in this case ESET Cybersecurity). I turned off realtime file system protection and instantly RDC and (and also SplashTop desktop, which does the same thing) got back to normal speed.

0

Try tweaking the Display settings on the Mac OSX RDP client.

Go to RDC->Preferences->Display, remove some of the "expensive" options in the "while connected" section (such as: show desktop background, show themes, etc...).

1
0

I was having the same issue with both CoRD and Windows RDP. What fixed it for me was adding more memory (I went from 4GB to 8GB).

0

In my experience connecting to a low-spec'ed Windows 10 box (older second generation Core i5 with 4GB RAM) with RDP from OS X is severely affected by real-time malware/spyware/antivirus scanning. Disabling Microsoft's own Windows Defender's real-time protection made the experience much more tolerable.

0

OK installing freerdp client (in my case, using homebrew) seemed to provide an increased performance over the built-in "Remote Desktop Connection" for me. Finally fast RDP on mac :)

 $brew install freerdp
 $ xfreerdp hostname_or_ip ...

This thread mentions various other clients as well, FWIW, including CoRD (now retired), though for me CoRD seemed still slow'ish, and is built on rdesktop instead of FreeRDP (not sure what that means but might help understand it's speed being comparable to the built in Remote Desktop Connection. (though rdesktop itself seemed more responsive than CoRD to me, for whatever reason).

Also see this thread, it mentions that there is a "Microsoft Remote Desktop" app in the app store, which, for me, is quite responsive...

0

In my experience, Slow can be interpreted two ways:

  • Takes a long time to connect
  • Choppy/slow performance once connected

In my case I was running into the first of these, but once connected, it was fine.

I use the Microsoft RDP App from the App Store, and it generally works great for my purposes, but one day it just starting taking ages to connect to two of 3 of my regularly connected systems. It has been bugging me for 6 months!

Today I thought I would check some other things. Turns out that it is the difference between username formats that causes the issue, though I am unsure why this would be the case.

  • UPN/Email address format (username@domain.com) takes 2-3 minutes to connect
  • DOMAIN\Username connects instantly

Hope this helps others out there.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy