Alright so I've had these problems for years now and no one knows what is the cause! My internet every other day or so kind of dies. If I have a torrent or download running it will continue at regular speeds. Also if I'm on a VOIP program I will be able to maintain talking to people. However, if I disconnect off Ventrilo and try to reconnect I won't be able to get back on.

Also, I cannot browse new websites or initiate any new connections it seems. It's really weird! The only thing I can do is maintain connections it seems.. not establish new ones. Sometimes I have to link them webpages because I can't load them and they'll have to tell me about it.. lol.

Anyways, we've gone through multiple routers and modems and RCN tech has been over many times but to no avail. They have no idea what the problem is. They even tried fixing some of the green boxes outside of the house but nothing.

Also, this just happens randomly. I'll do a speedtest and have 15 megs on the down and 2 on the up and then 1 second later, nothing. Internet gone. And the funny thing is that it is easily fixable. All I have to do is powercycle my equipment and bam. Instantly back up to full speeds.

I've called tech support many times and they have no idea. I've formatted my computer and the problem still exists. I've even tried turning off all other computers and devices in the house in case they were the problem. Still nothing.

Also, even if I turn off wireless the problem persists so it's not some guy in a car outside my house messing with me.

Honestly I'm kind of getting used to it at this point. Hah. If it's been a day or two and I'm near the basement I'll just restart my equipment so I won't have to a couple hours later when in a game. Oh, and it doesn't really effect gaming to be honest. If I'm playing TF2 and it happens the connection is still maintained and I can finish the game.

Anyways, I've never heard of anything like this before and I'll be surprised if I get an answer.


I had a similar problem a while back. It turned out to be a combination of two problems for me.

Problem 1: Wireless Interference

When I got my first wireless router, I bought a pair of 5 GHz cordless phones to replace the 2.4 GHz phones that I had before. Since the wireless-G router I bought operated at 2.4GHz, I didn't want any interference. Instead of throwing the old phones away, I tucked them away in a closet. Well, at some point my wife found them and set one up in her home office. Every time she would use the phone, the wireless internet would die for a short time. She would call me at work to tell me that the "internet was down". One evening she came to tell me that the internet was down again and she had one of the 2.4 GHz phones in her hand. They went to Goodwill the next day.

Solution: get rid of interfering devices

Problem 2: Cheap-o router

Getting rid of the 2.4 GHz cordless phones made my internet access rock solid... unless I used Bittorrent. At the time, I had a Linksys WRT54GS router which was supposed to be great for Bittorrent. The problem is that I had version 6 which is apparently a cost-reduced version. Instead of 16 MB of RAM and 4MB of flash memory like versions 1-4. My version 6 only had 8 MB of RAM and 2 MB of flash memory. If I had a lot of Bittorent connections open, the router would seize up somehow until some connections dropped, then start working again with the newly freed memory. Wash, rinse, repeat.

I fixed this problem by buying a router with more RAM. I ended up getting a refurbished WRT610N with 64 MB of RAM and 8 MB of flash memory.

Solution: Upgrade to a router with more RAM.


Sounds like a flaky DNS server. Your existing connections don't need DNS, so they're maintained, but you can't do DNS lookups to create new connections by hostname. To check this, look up an IP address for Google or something while everything is working OK (e.g., and then when it goes flaky, try loading the Google home page by IP address ( If it loads OK, then it's a DNS problem.

  • I think someone has mentioned this to me before and I tried it and it didn't work. I'll try again though next time it happens. – John Smith Aug 6 '11 at 16:21

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.