16

For example: If I type reddit.com, it autofills it to reddit.com/r/fffffffuuuuuuuuuuu based on my history.

I wanted to go to reddit.com, not F7U12. Any way to turn this off?

11

According to this bug report, google will never allow this to be turned off. At all. The hate is palpable.

  • 5
    Google knows better than you. They won't allow a setting to configure something they're sure the user is wrong about. And this is an example of the one thing I absolutely cannot stand about Google. – Zoey Oct 4 '15 at 18:49
3

Unfortunately, there's no way to turn off autocompletion in Chrome's omnibar.

Theoretically, if you just type reddit.com and press Enter (erasing any additional autocompletion), it should start autocompleting to that. In practice, however, you might have to clear your history to make it go away.

3

The Chromium devs don't want to implement it, see:

We have posted many times about why we generally don't provide options. Options carry high hidden costs, largely in terms of code complexity and testing burden. The former leads to more bugs and slows down development and implementation of future work, while the latter often manifests as large numbers of bugs in non-default setting combinations that aren't tested. These are not theoretical concerns; a number of us on the team are ex-Firefox developers and speak from experience with its codebase. Additionally, options don't solve problems for most users because very few users ever change any options in the browser or even know what options exist; and as options proliferate it becomes difficult to find and understand the potential choices even for people who don't mind wading through them. See the Seamonkey or VLC options pages for examples. Finally, options reduce the chance that the design team actually solves the real problems underlying some design decision, because they become an easy "fix" for any perceived issue.

https://bugs.chromium.org/p/chromium/issues/detail?id=334300#c43

2

As other have pointed out, I don't think it's possible to turn off address completion from your history. The only way to stop Chrome from completing URLs is to remove the specific URLs from your history. You can do this at chrome://history or in the Omnibox by typing the beginning of the address and then highlighting the one you want to delete and pressing shift+delete.

Check out chrome://predictors to see which URLs Chrome is going to complete based on what you type. As a bonus, this page also offers insight into what you have previously typed in the Omnibox to navigate to a certain address. Pretty cool, in my opinion.

1

The reason that’s happening is because you visited that page enough times to convince Chrome that you frequent it (at least more than other reddit pages), and so when you type the beginning of the URL, it automatically fills in the rest, assuming that you want to go there again.

You can always just ignore what it fills and continue typing the rest of the URL or press Delete.

Another option is to open your History, click **Edit items…*, select the URL in question (perhaps more than one instance), then click Remove selected items. This way, it is removed from your history and so Chrome won’t make assumptions.

(The history-editing function is still not that great in Chrome, so it may be easier if you use a history-enhancing extension like History 2, History2, or Recent History.)

Failing that, you can resort to some hacking. You can use an SQLITE3 tool/editor/browser/manager to edit the history files Archived History and History to remove the URL. This method is not pleasant, but technically, you don’t have to do it correctly, you can simply edit the URL to be something else, and that will still have the desired effect.

-2

This has long since been an annoyance for me, and just recently figured out a slight workaround. The problem resides in using google as a search engine, changing this fixes the problem OR using an alternate google search url:

https://www.google.com/#q=%s - This disables autocompletion while still using google as a search engine. You must clear search history before using this, otherwise it will still autocomplete to old searches.

Using 'https://www.google.com/search?q=%s' will still autocomplete.

Only downside to this, it does disable suggestions, which are helpful sometimes. It is, however, a simple fix to a huge annoyance.

-3

Updated as of July 2012:

  1. Click the "wrench" icon
  2. Choose Settings
  3. On the very bottom, click Show advanced settings...
  4. Find the Privacy section
  5. Uncheck the option "Use a prediction service to help complete searches and URLs typed in the address bar"
  6. The setting is automatically saved. It is safe to close the settings tab now.
  • 6
    That's not what the question is talking about. The "prediction service" setting does not disable inline autocomplete because items from the history or bookmarks still get pooled into the suggestions. The annoying part of it is that you have to either delete the inline suggestion or continue typing. What's worse is that you can't always delete the autocompletion. Try typing weather/ in the omnibox for example. Now everytime you want to search for weather in google, you get a 404 error instead because Chrome thinks weather/ is a URL until you clear the history. – Adam Feb 21 '13 at 3:15
  • NOTE: the specific example of a weather/ typo only really works if you have an ISP who is catching 404 errors and you haven't disabled it through whatever ISP preferences you have to opt out of, in which case the mistyped URL registers as a valid one and your ISP wins the marketing annoyance campaign. – Adam Feb 21 '13 at 4:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.