2

I use Internet Explorer 9 for exactly one web site as that web site makes use of ActiveX. Since I use the same site all the time, I noticed that IE 9 keeps the URL I visit in frequently used URL list. I've disabled indexing of IE information in Indexing Options (no effect). I have enabled "Delete Browsing History on Exit" option (no effect).

Two questions towards a solution to my problem:

  • How to make IE 9 completely forget Frequently Visited Sites, without storing any traces?

  • Is there a plugin that clears Frequently Visited Sites automatically when the browser is closed?

  • Did you try reinstalling? – soandos Aug 7 '11 at 9:23
  • 1
    Is this site maybe your home page? – Daniel Beck Aug 7 '11 at 10:30
  • 1
    @Daniel about:blank has been my favorite homepage for about 15 years, already, since I first installed a browser :). – Eugene Mayevski 'Callback Aug 7 '11 at 11:04
1

Since it's close-source, you never know. You will have to run in in some sandbox environment, or to be 100% sure, in virtual environment with HDD snapshot.

| improve this answer | |
1

Sandboxie is your best bet to deny any history logging when the browser itself malfunctions.

enter image description here


The specific problem you describe in your comment is simply because of this option:

enter image description here

You have once visited the site outside the InPrivate mode, resulting in the frequently visited entry.

| improve this answer | |
  • Thank you for the link. On a side note I would like to welcome you to revert your edits cause they are not correct -- I have no problems with browser history. It's cleared perfectly well. The problem is in Frequently Visited Sites feature, not the history. Next, the problem is specific to InPrivate mode and you've completely removed all references to this mode. – Eugene Mayevski 'Callback Aug 7 '11 at 11:08
  • that box was never checked and it's unchecked now. Also, InPrivate mode suggests that nothing is stored no matter of other settings, however this seems to be not the case. I.e. it's a problem probably specific to InPrivate mode. If it were that simple, I would not bother anyone with such questions. – Eugene Mayevski 'Callback Aug 7 '11 at 11:34
  • Right now, as we've been talking, IE 9 added a site to frequently used again despite all chosen options and surely I used InPrivate mode. Reinstalling Windows is not an option as well as creating other user. I guess my best option would be to create an IE plugin that will clear all junk upon closing myself. – Eugene Mayevski 'Callback Aug 7 '11 at 17:16
  • I don't understand you. The plugin can go and clear that damn list for me, and that is what I was looking for in my secondary question. As I didn't ever visit CNN site before, visiting it now didn't bring it to the list, but visiting the site in question did. I'll try playing with some other sites to find the pattern (if it exists). – Eugene Mayevski 'Callback Aug 7 '11 at 17:41
  • @EugeneMayevski'EldoSCorp let us continue this discussion in chat – Tamara Wijsman Aug 7 '11 at 17:57
0

You can disable the autofill from internet settings -> contetnt -> autofil and take off the checkmark from all spots. If that's what you ment. Not sure if the names of menus are correct because my IE isn't english.

| improve this answer | |
  • The OP is not talking about content auto-filling, he's talking about browser history. – Tamara Wijsman Aug 7 '11 at 10:58
  • Yes, I know, but there is a settings which enables/disables the autocomplete on addressbar. Isn't that what the OP ment? – tlehtil Aug 7 '11 at 13:46
  • Ah, there indeed is, my bad. But that doesn't remove his browser history or frequently visited sites from existance... – Tamara Wijsman Aug 7 '11 at 13:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.