6

I'm trying to connect a Windows 7 server and an Ubuntu 11.04 client with Synergy 1.3.7.

I have checked that the server is listening on the correct port by running netstat -ano. I have also checked that the client can connect to the server on this port with telnet.

  • The server has the screen name Rupert-PC.

    Screenshot

  • The server is setup with both the server screen, Rupert-PC, and the client screen, Ubuntu.

    Screenshot

I have checked that the client is called ubuntu by running hostname. I have also tried specifying it directly by called synergyc -f --name ubuntu 000.000.000.0.

However, the client still can't connect and gives the following error:

Error server refused client with name "ubuntu"

Any ideas on what else I can check to get this working?

Edit: I've also tried using Synergy 1.4.3 beta but got the same result.

1
  • 1
    The solution was simple: I changed the server screen name from Rupert-PC to rupert. I'm not sure why this worked. Maybe it didn't like the capital letters or the hyphen. Unfortunately I can't add this as an answer for another 8 hours as my reputation is below 100. I'll to remember to do so then. – Rupert Madden-Abbott Aug 9 '11 at 0:29
14

The problem is with the hyphen. I was facing the same issue. When I removed the '-' from the client configuration's screen name and from the host's server configuration screen name. It worked.

1
  • 2
    Also remember to stop and start your server after making the change – Zaptree Oct 4 '16 at 3:50
4

The problem was with the server screen name, "Rupert-PC". By using "rupert" instead, synergy worked fine.

This may either be a problem with capitalisation or the hyphen.

1

For below setup

  • ubuntu 15.04 (acting as server)
  • windows 10 (acting as client)
  • Synergy 1.7.4 stable version and
  • both ubuntu and windows hostnames containing - and capitals

Had to write a configuration file which had both server and client screen names to make this work me. (Also had to kill all synergy processes and restart)

Below is the configuration file content and here's reference link

section: screens
subu:
    halfDuplexCapsLock = false
    halfDuplexNumLock = false
    halfDuplexScrollLock = false
    xtestIsXineramaUnaware = false
    switchCorners = none 
    switchCornerSize = 0

    swin:
            halfDuplexCapsLock = false
            halfDuplexNumLock = false
            halfDuplexScrollLock = false
            xtestIsXineramaUnaware = false
            switchCorners = none
            switchCornerSize = 0

end

section: aliases
end

section: links
subu:
right = swin
swin:
left = subu

end

section: options
    relativeMouseMoves = false
    screenSaverSync = true
    win32KeepForeground = false
    switchCorners = none 
   switchCornerSize = 0
end
1

I got this to work when I removed special characters from my screen name and made sure I used the same name (client screen name & client name in server).

I was using a Mac as the client (1.4.1) and Windows as the server (1.6.3).

-1

Things you should be taking care:

  1. make sure the two systems are in same network (some if u wifi virtualbox adaptor it will take some other ip range), so u can conform it by changing client to server or vice versa
  2. make sure port number are same (default it will be same so can ignore it if not changed)
  3. make sure the screen name is same client and server

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.