It is not entirely a problem with Finder. It happens system-wise.

Whenever I create a file in osx, the permission is always set to owner read/write and the rest read only

-rw-r--r--  1 me  mygroup  0  9 Aug 23:18 test

How can I set to 'owner and group read/write'?

up vote 0 down vote accepted

There is a post at Apple Discussion forums about using either /etc/launchd.conf or /etc/launchd-user.conf to set the system-wide umask.

Two files were created: /etc/launchd.conf (for system-wide global umask) or /etc/launchd-user.conf (for user-specific global umask). The contents of each were simply the single umask command, umask 002 or (umask u=rwx,g=rwx,o=rx, I can't remember which variant I used - they're functionally the same, though).

There's also a mention of TinkerTool System, which would help do this in a GUI. However, the discussion ends with the caveat that this may work in the Terminal but not in Finder. I have not tested this myself.

TinkerTool System

  • This comes with a big warning that if it succeeds, it may have unexpected consequences. For example, I know someone who experimented with locking down the default perms (no access for group or others), then changed their network settings and some of the network settings files wound up unreadable and the network became unusable. In your case, opening up permissions is more likely to create security holes than prevent things for working. – Gordon Davisson Aug 9 '11 at 16:59

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.