43

I hate to have to ask this but... I've seemed to accidentally hit a couple hot-keys and my Notepad is now showing text from Right-to-Left. What was the hot-key combo and what can I do to reverse it back to Left-to-Right?

7 Answers 7

45

Right click anywhere in notepad and uncheck right-to-left reading

3
  • 1
    Wow... I've never noticed that. Just for curiosity, do you know the hot-key equivelent?
    – RLH
    Aug 9, 2011 at 19:17
  • 7
    @RLH It is apparently Right or Left Ctrl+Shift depending on which direction you want it, but it doesn't work for me
    – Greg
    Aug 9, 2011 at 19:30
  • None of the shortcuts described in other answers worked for me in the standard Notepad (not Notepad++) version. You can however use Shift + F10 to open the context (or right-click) menu, then press R (if the operating system is English) or C (for the German version) to switch between the left to right and right to left reading orders. Note, that there are specific keyboards, having an extra key assigned to the context menu, see howtogeek.com/223037/…
    – pholpar
    May 25, 2020 at 19:33
24

Hotkey combo:

  • to write text from Right to Left, try Ctrl + Right Shift

  • to write text from Left to Right, try Ctrl + Left Shift

Or simply open Notepad again ;)

5
  • 3
    What a stupid short-cut, that can be easily hit by accident
    – Coops
    Apr 28, 2015 at 9:59
  • 1
    You can prevent accidents with AutoHotkey: just add this line to a .ahk file and run it: ^RShift::return. This will completely disable the hotkey in all programs including Notepad.
    – Gogowitsch
    Jun 4, 2015 at 19:30
  • I was excited by your autohotkey workaround, @gogowitsch. However I've found that it breaks ctrl+RShift+arrow for word highlighting, which I do a lot. I'm no AHK expert, anyone know how to tweak it to not have that problem?
    – Daryn
    Mar 23, 2017 at 19:05
  • 2
    Okay I've found what seems to work for me. Instead of swallowing ctrl + RShift and that messing up select-word shortcut, map RShift to be LShift so I never get RTL by mistake. RShift::LShift
    – Daryn
    Mar 23, 2017 at 19:22
  • this really should be the answer to this specific question. Oct 18, 2018 at 16:49
7

Try the following shortcuts:

Ctrl+Alt+R

Ctrl+Alt+L

6
  • 5
    Those do nothing for me Oct 9, 2012 at 15:13
  • 1
    These work in Notepad++ for changing LTR and RTL, maybe in other windows apps too?
    – n611x007
    Apr 26, 2013 at 15:47
  • 2
    Works for me in Notepad++. None of the other answers worked...
    – Meir
    Sep 2, 2013 at 9:15
  • 1
    Hooray for standards!
    – Ekevoo
    Jan 27, 2014 at 19:15
  • 1
    It works in Windows 10 too.
    – cdlvcdlv
    Aug 17, 2019 at 11:26
3

For Notepad++ users, use the "View" menu (when shortcuts fail due to some conflicts):

enter image description here

2
  • 1
    The original poster asked about Notepad. I assume this screenshot is from Notepad++, not from the version built-in in Windows. There are no such options in the menu of the standard version.
    – pholpar
    May 25, 2020 at 19:02
  • 1
    Correct, updated the answer. As I also came up this post when searching for Notepad++, others might benefit from my answer as well.
    – P-S
    May 29, 2020 at 7:46
0

To toggle between right and left text :

  1. strike the "menu" key (beside the space bar) - so you can see many options, with shortcuts underlined, like "Lecture de droite à gauche" in French

  2. strike the "L" key - in french version of Notepad - or an other letter if you have english or other language version

4
  • So you have translated accepted answer to keyboard? I think it should be a comment.
    – gronostaj
    Aug 8, 2014 at 12:27
  • I have a french version of win7, who is released with a french version of Notepad. Shortly, in the french version of Notepad, strike successively "menu" key and "L" key to toggle between right and left text. You can easily find what is the second key to strike if you have an english version, isn't ?
    – Brett.fr
    Aug 8, 2014 at 16:22
  • Yeah, I get what you mean, but it's basically the accepted answer with keypresses instead of clicks. Everyone who can use a keyboard efficiently would figure it out from the accepted answer. I don't think it's enough to post a separate answer.
    – gronostaj
    Aug 8, 2014 at 16:58
  • Sorry if my response was obvious for all.
    – Brett.fr
    Aug 8, 2014 at 20:24
0

As some may have been confused by the "specificity" of the Answer regarding the French version of Windows, and in keeping with the OP's actual question (and circumstance) the answer is as follows:

"Accidentally" 'hitting a couple of Hot Keys' causing the text to be Right Justified in Windows 7 Notepad was accomplished not by a "Hot Key" combination, (as some had suggested as CTRL-RShift or CTRL-Alt-R) but instead by using the Keyboard EQUIVALENT of [Right Click] & [Check]ing "Right to left Reading order".

This "accidental" keyboard sequence was [Menu Key] then [R].

To set things aright (using the keyboard, for the old-school typists), the sequence must repeated, i.e. [Menu Key] then [R].

To put out any "flames", let me reiterate; These steps are identical to the "Mouse-Centric" answer above, but in keeping with the OP's stated cause & problem.

0

In my case (Windows 7, Notepad++ 7.8.9 32bit), RTL suddenly arrived just in the "Find" boxes of the 4 tabs (Find, Replace, ind in Files, Mark) in the Find dialog. It doesn't affect the other boxes in those tabs (Replace with, Filters, Directory). It doesn't affect the main windows. Thanks to any try at solving. Versailles, Thu 01 Oct 2020 19:27:35 +0200

1
  • Returned to normal by shut down Notepad++ and relaunch. However I would like to know what caused this strange issue. Oct 1, 2020 at 17:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.