I try to download a PDF file using Internet Explorer 8. When I right click and save the file, it comes up with the error:

The file could not be written to the cache.

Internet explorer 8 error

I have already gone to Internet Options and and unchecked the box "Do not save encrypted pages to disk". I have also ran Internet Explorer with no add-ons, this didn't work either. i can download this on other pc's in my company though.


The server may be disallowing the caching of content.

According to Microsoft KB article 812935:

This issue may occur if any one or more of the following conditions are true:

  • The Do not save encrypted pages to disk check box is selected in Internet Explorer.
  • The server sends the "Cache-Control: No Store" header.
  • The server sends the "Cache-Control: No Cache" header.

Further down:

To work around this problem, make sure that 'Do Not Save Encrypted Files' check box is not checked and that the server does not send the "Cache-Control: No Store" or the "Cache-Control: No Cache" header.

Note This method does not work if the server uses the "Cache-Control: No Cache" header.

  • •The Do not save encrypted pages to disk check box is selected in Internet Explorer. Is unchecked I can download this file on another pc in my company but its just this one where it wont work. sorry i do no understand what you mean by Cache Control? – ben950 Aug 11 '11 at 14:06
  • @ben950 - Oh, you can download it on other computers? Hmm, probably not the server controlling the cache then. You should add that information (along with any other things you've tried) to your question. :) Here's something to check: Have you got enough disk space? Have you tried clearing your IE cache? – Ƭᴇcʜιᴇ007 Aug 11 '11 at 14:31
  • I have got enough disk space about 80GB Free. i have tried clearing the cache and this didnt work either – ben950 Aug 11 '11 at 14:45
  • Weird. Have you tried resetting IE (Internet Options->Advanced Tab->Reset"? If you log into the problematic computer as another user, does it work? Beyond those, I'm out of ideas (for now). :) – Ƭᴇcʜιᴇ007 Aug 11 '11 at 14:50
  • i have tried to reset the browser and this did not work either. i will get another user to try and login on that pc and see if the same things occour – ben950 Aug 11 '11 at 15:26

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.