6

I'm sort-of new to Linux, and new to Linux Mint 11.

About once a day the UI will completely freeze - except the mouse will move. It won't respond to any clicks or any keyboard ctrl+alt+delete, so I can't actually DO anything, but the mouse does move. Also, if I'm listening to music, that'll keep playing..

I am running an ssh server on that box and I can ssh into the server while this is running.

So, how can I begin to debug this?

5
  • Please start by providing us with some log information. 'dmesg', '/var/log/syslog' - those may hold some hints Aug 11 '11 at 18:10
  • ... does killing the server (with telinit 3 and then telinit 4) alleviate the issue, or do you have to reboot?
    – new123456
    Aug 11 '11 at 18:35
  • i did telinit 3 then telinit 4 (neither provided any output), and i don't see anything different on my box
    – roberta
    Aug 11 '11 at 18:49
  • i looked through /var/log/syslog and there are no events within about a half hour before/after 12:53pm (which is the time frozen on my taskbar)
    – roberta
    Aug 11 '11 at 18:49
  • I had the same problem on my Xubuntu install. Most of the time when leaving Chrome open for a while. I suspect a memory leak.
    – digitxp
    Aug 27 '11 at 4:05
3

There is another way besides putting it to sleep.

Press Ctrl-Alt-F1, login. Type

sudo killall gnome-shell

Then, press Ctrl-Alt-F7. And everything should be fine again, but it's pretty annoying to it this often.

2

In short: try just type your password, press enter. This worked for me and I had all of the same symptoms:

  • UI will completely freeze: x
  • except the mouse will move: x
  • won't respond to any clicks or keyboard: x
  • not even ctrl+alt+delete: x
  • music will continue play: x

This won't answer "how to debug this" but it may get your computer usable without having to resort to killing anything, so that you can begin to debug this.

You are not telling us if this happens suddenly while doing something, or if it happens if you leave the computer for a little bit.

In my case, this happens if I leave for a short time. I.e. when I come back, the screen looks exactly as when I left it and it won't respond to anything - yet I can move the mouse.

What I found out is that for some reason it is only rendering that frame over and over, however beneath it is all active. It is actually prompting me for a password and all I need to do is enter it in the dark and then it is all functioning again.

1

Happens to me too on my laptop. I found out that putting it to sleep and waking it up gets things going again. It doesn't fix it, but avoids data loss from rebooting.

1

I was messing around and found that the reason why it's doing this is because there are old, corrupt or no drivers. For me it was my graphics driver. Try re-installing the graphics driver. It helped a lot.

These are the commands I used:

sudo apt-get install fglrx
sudo reboot

After that drivers are installed. Now it is necessary to install the pxpress package that switches graphics:

sudo apt-get install fglrx-pxpress

You should now get a message that the discrete card is activated. Reboot system again.

sudo reboot

After the restart you can see that the Radeon card is active with this:

inxi -G

Now we need AMD Catalyst Center for switching graphic cards:

sudo apt-get install fglrx-amdcccle
sudo reboot

After reboot start AMD Catalyst Center with this:

sudo amdcccle

And change graphics to Integrated to see if everything works.

Always start amdccle with sudo when switching graphic cards.

Everything works great for me now.

0

I get this issue on a fujitsu P900. i7. I place two ribbon of memmory. one 4GB and the other is 8GB.I use the pc before for months, I make lot of tuff works / task with it, mostly converting my private DVD to mkv. to save time or win on time, I gave the PC lot of job to do, I come after 2 days. and all is well done.

Since, I add this ribbon, thinking to upgrade for quicker and better performance, but unfortunately, I get bad experience of freezing or hang on, but, I can see my screen clear and nice with no black box or else. the only things working is my mouse. I get this several times and , I just have to restart my pc to get out of this.

fortunately, i go back to understand why this happens, and i can guess that it is the latest my memory that i add can casue this. i remove it and let the Pc operate with thE 8GB ribbon.

And the problem is gone..

this is how I solved my freeze problem.. Yours may differ.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.