How can I reinstall Windows Installer 4.5 on a Windows Vista SP1? When I run the redistributable installer, it simply says that the update is not needed (msiexec /? indeed returns the same version).

The actual problem i'm facing is related to the inability of installing any updates (i.e. SP2) due to a (apparently) corrupted behavior of Windows Installer. When I try to start the EAP service (WLAN autoconfig dependency), it mentions that the EAP service is not a valid Win32 instance, erroring with "193, 0xc1".

Any ideas?

migrated from serverfault.com Aug 11 '11 at 21:43

This question came from our site for system and network administrators.

  • Have you tried uninstalling the windows installer service first? – MaQleod Aug 11 '11 at 21:46
  • how can i do that? – XXL Aug 11 '11 at 21:50
  • It should be listed in Add/Remove Programs. – music2myear Aug 11 '11 at 22:01
  • Im not 100% sure here, but, you could have bigger problems... Possibly try running SFC /SCANNOW from an elevated command line. – William Hilsum Aug 11 '11 at 22:02
  • yes, i have performed sfc /scannow prior to this and it has reported some errors that it could not correct, as well. suggestions? – XXL Aug 11 '11 at 22:19

To force a reinstall you'll need to run the installer with the correct options.

This site has a good list of the various options.

You'll need to get the .msi package version of the Windows Installer. Once you've got that, go to Start > Run, and type the following and click OK:

msiexec /fams "c:\...pathtoinstaller\installname.msi"
  • any idea where i can get the .msi version from? microsoft seems to only offer .msu – XXL Aug 11 '11 at 22:18
  • The MSU should probably work as well. Give it a try. The worst it'll do is not work. – music2myear Aug 11 '11 at 22:22
  • MSI stands for Microsoft Scripted Installer (I think). MSU is an Update rather and an installer. – music2myear Aug 11 '11 at 22:24
  • .msu didn't work, Microsoft does not distribute Windows Installer in an .msi from what i see.. so kinda hitting a brick wall here – XXL Aug 11 '11 at 22:28
  • @XXL, MSU files are run by msiexec, the same program that handles MSI files; eg msiexec /f Windows6.0-KB942288-v2-x86.msu – Synetech Aug 13 '11 at 0:13

I assume you are using the file Windows6.0-KB942288-v2-x86.msu correct?

The redistributable doesn’t return any relevant options, but try running a repair by using Windows Installer’s /f switch. You can also try some of the arguments for the repair function:

Repair Options
    /f[p|e|c|m|s|o|d|a|u|v] <Product.msi | ProductCode>
        Repairs a product
        p - only if file is missing
        o - if file is missing or an older version is installed (default)
        e - if file is missing or an equal or older version is installed
        d - if file is missing or a different version is installed
        c - if file is missing or checksum does not match the calculated value
        a - forces all files to be reinstalled
        u - all required user-specific registry entries (default)
        m - all required computer-specific registry entries (default)
        s - all existing shortcuts (default)
        v - runs from source and recaches local package

Failing that, try uninstalling it first with the /uninstall switch.

If all else fails, you can resort to the Windows Installer CleanUp Utility (no need to bother running manually MSIZap; MSICUU does it for you). (However, according to this page, it does not remove Windows Installer—which I suppose makes sense to a degree—but it may be worth a shot as a last resort anyway.)

  • unfortunately, none of this has resulted in any progress :( – XXL Aug 12 '11 at 17:19
  • You could try manually replacing the files. You would need something like 7-Zip to extract everything from Windows6.0-KB942288-v2-x86.msu. Unfortunately, the files are not named correctly in the archive, so you’ll have to rename them. In the meantime, I’m examining it to figure out how to wipe it out (at least enough) to allow you to reinstall it. – Synetech Aug 13 '11 at 0:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.