2

It happened overnight, 2 nights ago - I'm not sure what happened, but I've tried spraying compressed air, lifting up the keys and pushing hard, toggling from side to side, pushing down hard on the plastic membrane, and applying heat via a hair dryer.

Any suggestions for what I can do? I feel like in the very worst case then I could download some software program to rewire function+0 to 'o' and function+- to 'i'?

2
  • 1
    Check the Keyboard Viewer... and take it to an Apple store!
    – jtbandes
    Aug 13 '11 at 19:19
  • :) will do - i'm tired of typing in 1337speak
    – Zack Burt
    Aug 13 '11 at 19:25
0

I would start by testing to see if it's a hardware related issue or a software related issue. Try and boot from the usb stick that came with the machine to test if the keys work there.

If it's software related you might want to look at reinstalling or trying to figure out what you did to make it stop working and rectify. It might be best if you can't easily solve the issue to consider a hardware related issue and you may need to take it to Apple for repair.

1
  • Nothing worked. I ultimately went to the Apple store and they dealt with the issue. Very nice of them to replace it since I was out of warranty!
    – Zack Burt
    Aug 31 '11 at 22:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.