Recently I resized my D: partition, which is about 350 GB large and formatted as NTFS. I resized it with GParted on Ubuntu and I got and error saying

Current NTFS volume size is bigger than the device size
Corrupt partition table or incorrect device partitioning?

And now I cannot access it and the system keep saying that the filesystem is corrupted. I have tried making a backup of the actual state of drive now but I got an error while doing that with Clonezilla. I want to try repairing that with testdisk but I am afraid of losing the data on this partition completely.

Do you have any other ideas how to do this?

  • A few questions: - Do you have a backup? - What kind of drive is this (make/model)? - What were you trying to do in GParted? – digitxp Aug 13 '11 at 21:20
  • I do not have a backup (yeah, I know I should have one...), it's Seagate ST9500420ASG 500GB, and I was trying to make this partition smaller and I got an error while doing that. – Patryk Aug 13 '11 at 21:28

Testdisk lets you recover the data to another drive so you should be ok to run it.

  • Ok, so somehow I have accessed my data from TestDisk but I can copy them only onto my linux partition (ext4). Is it possible to copy it somewhere else ? For instance to an external hard drive ? – Patryk Aug 14 '11 at 11:22
  • @user73377 Yes once you've recovered the data you can move it to any mounted drive. Just plug in your hard drive and if it doesn't automatically mount itself just select it from the places menu. – Col Aug 14 '11 at 12:18
  • I can see it in the menu but i cannot access it (ERROR: Error mounting: mount exited with exit code 21: fuse: mount failed: Device or resource busy) and I need to mount it somehow in /mnt/ or somewhere else to use it inside TestDisk. Here is the link to my problem : askubuntu.com/questions/57063/… – Patryk Aug 14 '11 at 14:41

Using Windows XP Recovery console, type CHKDSK C: /f /r and press Enter

Using Vista/7 Recovery Environment, load the Command Prompt and type CHKDSK C: /f /r

Replcae C: with the partition you are resizing

  • I have tried: chkdsk d: /f and chkdsk d: /r but I got an error : link Although I have used it while being in normal console not in recovery one. – Patryk Aug 13 '11 at 22:02
  • Recovery Console has a /p switch for "check anyways" mode. It looks like you're using Vista or 7 from that screenshot. You may need to use an application like GetDataBackNTFS to read the contents and get it back. Try doing the CHKDSK in the recovery environment. Do you know how to get there? – Canadian Luke Aug 13 '11 at 22:35
  • I have tried to go there from grub (because I have ubuntu isntalled as well) but I got an error on my acer e-recovery management saying "Please complete operating system setup process before doing system recovery". Now I have used Windows 7 USB to launch it and I got the same error : "... chkdsk cannot be used for RAW file systems ..." – Patryk Aug 14 '11 at 8:42
  • Weird... It always worked for me :( Best guess would be a recovery program then, like GetDataBackNTFS. Or some other program that will read the raw data from the hard drive – Canadian Luke Aug 15 '11 at 0:18
  • Actually, try going to ntfs.com – Canadian Luke Aug 15 '11 at 0:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.