I am running Fedora from VirtualBox with Windows XP as the OS host. How do I mount the selected shared folder in Linux?

migrated from serverfault.com Aug 14 '11 at 19:16

This question came from our site for system and network administrators.


Rather old but just in case:

mount.vboxsf -w nameofsharedfolderinvbox /destination/path/on/linux

Also to add it to fstab:

nameofsharedfolderinvbox  /destination/path/on/linux  vboxsf  defaults  0 0

Obvious question, does /home/user/vsharebox exist?

Are the Guest Additions installed in your Fedora VM and are they up to date with the running kernel?

  • Yes, the folder is there. As for the guest additions, I really didn't check. The monitor resolutions works, so does the mouse capture functionality, so I guess it runs properly. – cmserv Jul 15 '09 at 16:31
  • Which version of VirtualBox are you running? Have you upgraded to 3.0.x? Just to be safe, go ahead and do the Devices->Install Guest Additions to present the CD to Fedora. Then run the appropriate VBoxLinuxAdditions script from wherever the CD mounts. After it installs, simply run service vboxadd start and assuming it starts successfullly, then try your mount again. – TCampbell Jul 15 '09 at 17:20
  • The VirtualBox is v3.0.2. I restarted the script and the machine and got: [root@xyz user]# mount -t vboxsf Workspace /home/user/Workspace /sbin/mount.vboxsf: mounting failed with the error: Protocol error – cmserv Jul 15 '09 at 20:29
  • If you install Guest Additions, make sure you reboot. If you set the share to automount in VirtualBox, after rebooting it will show up at /media/[sharename] – Michael Munsey Aug 28 '13 at 23:07

Not sure what the command is exaclty for fedora, but here are a couple of examples:

sudo smbmount \\\\\\c\$ /mnt/localFolder/ -o username=administrator
mount -t cifs \\\\WindowsHostName\\utility /mnt/localfolder -o username=administrator

And you might need a package like smbfs or samba-client.

  • I think you misunderstood my question. It's not a network drive. I pointed to a folder going to Devices->Share Folders...->Machine Folders. I tried "mount -t vboxsf <name> /home/user/vsharebox" but it failed with "sbin/mount.vboxsf: mounting failed with the error: No such file or directory". – cmserv Jul 15 '09 at 13:00

I mounted it on a Debian distro in VirtualBox and it worked without a problem:

(Check if needed http://wvarner.blogspot.com/2008/05/installing-virtualbox-guest-additions.html)

sh /cdrom/VBoxLinuxAdditions.run mount -t vboxsf

  • 1
    if you want the shared folder be available permanently, use: 1. mkdir /mnt/your_folder 2. sudo nano /etc/rc.local 3.add line: mount -t vboxsf -w -o uid=1000,gid=1000 your_folder /mnt/your_folder 4. save and reboot – Alexey Nov 11 '10 at 11:13

for fedora 10 [i modified the debian command posted by cmserv, above]: sudo sh /media/VBOXADDITIONS_2.2.2_46594/VBoxLinuxAdditions-x86.run vfs-module

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.