My current workplace uses Macs and my old workplaces used Windows. In my old workplaces I heavily used Outlook's Task functionality to manage my workload.

I understand that the Task functionality in Outlook 2011 for Mac is heavily limited so I was very pleased to find this useful "how-to" on making the most of Tasks.

My problem is that my tasks don't appear in the Task folder, or anywhere else for that matter. Even if I search for a the title of a task I've recently found I still can't find them.

After some Googling I found this forum thread that suggests it may be a problem with the Outlook database, which points to a Microsoft KB.

So I went through all of the recommended steps on rebuilding/ adding a new identity using the "Microsoft Database Utility" - the theory being that if I create a new identity I can test the task creation using a "blank slate" identity.

When I change the default identity to my newly created identity using the Microsoft Database Utility (have to restart the computer) Task creation still doesn't work.

Any ideas appreciated, I really miss the task functionality in Outlook 2010 for Windows.


You may have already found this answer from Microsoft, but in short - you need to enable Spotlight search. Outlook uses OS X's built in search engine for its own search, and apparently also for displaying Tasks. In short, a Task won't appear until it's been indexed.


You may have to rebuild Spotlight's index, more info on how to do that here:


This worked for me.

  • 1
    It's 2014 and this is still the solution. Thanks. Apr 30 '14 at 16:42

Here's what worked for me when my Outlook for Mac tasks disappeared one morning.

I believe it had to do running out of harddisk space and Spotlight not being able to index things properly (I got a warning that my "start-up disk is full, please make room on your hard disk").

So I removed a bunch of files, restarted, waited some time for Spotlight to do its thing, started up Outlook and my tasks were there once again.


I'm using El Capitan with Outlook 2016. My tasks would not show up, though I could add a task and have it show up in my phone and in OWA. I got my tasks to show up by adding and removing my Outlook profile directory to Spotlight Privacy.

I used Microsoft's KB article (linked above) and found these steps worked for me:

  1. Close Outlook.
  2. Open System Preferences > Spotlight > Privacy
  3. Drag ~/Library/Group Containers/UBF8T346G9.Office/Outlook/Outlook 15 Profiles/ to the Spotlight Privacy list (or click "+" and navigate to the folder). If you can't find your Library folder: MacWorld: How to view the ~/Library folder
  4. Click the "-" to remove the folder.
  5. Exit System Preferences.
  6. Open Outlook 2016.

I then saw my tasks.


I exported tasks to desktop and checked the box for "delete upon export", then I reimported.

This solved the problem of tasks not appearing.

  • Thank you Blh. I gave your export/ delete/ re-import method a crack and didn't have any luck with my system. Office 2011 for Mac has been a massive disappointment compared to Office 2010 for Windows. Oct 4 '11 at 0:54

This happened to me, and I think I fixed it.

In my case, I had set Spotlight to ignore a Microsoft User Data folder (i.e., don't index it), because my Mac's "Today" and "Past Week" searches are spoiled by hundreds of irrelevant Outlook files that clog the list of search results.

I thought I had found a clever solution. Nope.

It seems that Spotlight must be allowed to index that folder. Otherwise, Outlook 2011 won't show my Tasks.

I closed Outlook, went back to Spotlight prefs, removed that User Data folder from the Privacy list, and my tasks reappeared when I restarted Outlook. Only took a minute or two.


Same problem today, got it working when I Setup the account under the Exchange option

For me, manually configured IMAP would only work for emails. I don't know if only emails are included under IMAP or maybe I missed a configuration setting. In outlook things just wouldn't appear even after showing in progress window and in Mac Mail tasks/contacts/etc would result in "Retrieval using the IMAP4 protocol failed for the following message". It's outside my realm of expertise, but this was my fix. I hope this is of some use to others who might stumble across this page 4 years down the road in 2019.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.