I have tried every way I know how to get Windows 7 SP1 to install. It fails every time. Below is what looks like the relevant contents of the CBS.Log file. If there are further details that would help or more information I can gather, I will get it.

2011-08-15 10:32:52, Info                  CBS    Startup: Package: Package_for_KB976902~31bf3856ad364e35~amd64~~ completed startup processing, new state: Installed, original: Installed, targeted: Installed.  hr = 0x80070490
2011-08-15 10:32:52, Info                  CBS    WER: Generating failure report for package: Package_for_KB976932~31bf3856ad364e35~amd64~~, status: 0x80070490, failure source: CBS Other, start state: Partially Installed, target state: Installed, client id: SP Coordinater Engine
2011-08-15 10:32:52, Info                  CBS    Failed to query DisableWerReporting flag.  Assuming not set... [HRESULT = 0x80070002 - ERROR_FILE_NOT_FOUND]
2011-08-15 10:32:52, Info                  CBS    Failed to add %windir%\winsxs\pending.xml to WER report because it is missing.  Continuing without it...
2011-08-15 10:32:52, Info                  CBS    Failed to add %windir%\winsxs\pending.xml.bad to WER report because it is missing.  Continuing without it...
2011-08-15 10:32:52, Info                  CBS    SQM: Reporting package change completion for package: Package_for_KB976932~31bf3856ad364e35~amd64~~, current: Partially Installed, original: Partially Installed, target: Installed, status: 0x80070490, failure source: CBS Other, failure details: "(null)", client id: SP Coordinater Engine, initiated offline: False, execution sequence: 517, first merged sequence: 517
2011-08-15 10:32:52, Info                  CBS    SQM: Upload requested for report: PackageChangeEnd_Package_for_KB976932~31bf3856ad364e35~amd64~~, session id: 101457924, sample type: Standard
2011-08-15 10:32:52, Info                  CBS    SQM: Ignoring upload request because the sample type is not enabled: Standard

I have downloaded the service pack and ran it from the EXE, I have installed it from Windows Update, I have ran all the "troubleshooting" trouble shots I could find. Nothing has worked so far.

Any advice would be appreciated.

  • Are you dual booting? Installing SP1 seems to fail if the Windows boot loader isn't the primary boot loader. – Eric Y Dec 18 '12 at 18:37
  • I am not. But thanks for the suggestion. – CleverPatrick Dec 21 '12 at 19:53

It looks like the hr = 0x80070490 is an error. Which led me eventually to: http://support.microsoft.com/kb/971058 from what I can tell there are missing components or something not setup properly, but the above links is to a "fixit" that should take care of the problem

  • tried that. didn't work. Thanks for the suggestion. – CleverPatrick Aug 16 '11 at 0:21

If the solution by tkrabec does not solve it, download and run the SUR tool, once this is done perform a safe boot and install the downloaded SP1 exe.

To Boot Clean in Windows 7 and Vista

Accessing the System Configuration Utility

  1. Click Start, type, msconfig in the search box and press Enter

Configure Selective Startup options

  1. On the General tab, choose Selective Startup
  2. Uncheck Load Startup Items
  3. Select the Services tab
  4. Check Hide all Microsoft services
  5. Click Disable all
  6. Click on OK
  7. Click Restart.

After performing the necessary steps and installing SP1, restore your system to normal boot by doing the following:

  1. Click Start type msconfig in the search box and press Enter
  2. On the General tab, choose Normal Startup
  3. Click Ok
  4. Click Yes, when asked to restart your computer
  • Thanks for the suggestion. I was hopeful. But it did not help. The results were the same. – CleverPatrick Aug 16 '11 at 0:47
  • Uninstall your Security Software and try again – Moab Aug 16 '11 at 14:44
  • try this support.microsoft.com/kb/958044 – swapyonubuntu Nov 16 '12 at 17:52
  • As swapyonubuntu recommended, you should follow the kb and try the update readiness which is vital plus an sfc /scannow with a repair installation. You should also try: support.microsoft.com/kb/971058. During the installation, make sure your Antivirus suite is turned off. An ISO image can also be obtained to try upgrading separately. – Lasith Jan 30 '13 at 13:41

I had this problem today! Fixed it by running system file integirty tool, but in the past malware was also the culprit

  • Do you mean the System File Checker? – Dennis Jan 30 '13 at 13:36
  • @Ramhound Users with less than 50 reputation can't add comments. This was already pointed out to you before. It would be nice to expand this answer to explain how exactly the problem was solved. – slhck Jan 30 '13 at 14:04
  • @slhck - I figured it could be made into a comment by a moderator. I often see lots of "I had this problem too" answers on old questions posted by users ( who joined within seconds before posting ) and often have a computer services/repair website connected to their profile. – Ramhound Jan 30 '13 at 14:18
  • @Ramhound It talks about how they fixed it so it could stay as an answer if the poster improves it to add more detail. – slhck Jan 30 '13 at 14:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.