I've got a rather interesting problem cropping up on a few machines right now. I've got a bunch of Windows 7 machines networked with a workgroup at home. I used to be able to simply open the "Run" box and type in "\\computername\sharename" to browse the contents of other machines, but recently this has stopped working. In fact, it doesn't even work when attempting to browse to shares on this very computer. Observe:

Run Dialog

Network Browse Failed

(Reliant is, of course, the machine used to take these screenshots)

The effect is the same with both UNC names and IP addresses. The error message (in this case 0x80070002) actually seems to vary from one attempt to the next, sometimes reading "Network path not found". Ive done a bit of googling on each of the various error messages that come up, but I have found nothing.

The odd thing about this situation is that I can still access all shares by mapping them as network drives, as illustrated here:

Mapping network drive


At the moment I can work around the problem by simply mapping each drive as needed, but it's a tedious and annoying process. Any suggestions/questions are welcome.

  • Weird, the same thing is happening on my machine. This has been driving me nuts. Aug 16, 2011 at 18:05
  • Is this on every machine or just one? Aug 22, 2011 at 17:58
  • It was on most machines, but not all of them. Chris's solution seems to have fixed it.
    – Fopedush
    Aug 22, 2011 at 18:01

10 Answers 10


OK, I figured it out. No idea if this is your problem, but here's my fix. I removed the "Network" icon using some registry tweak a "friend" gave me. It removed the following keys:


However this alleged friend failed to tell me that this also screws with your ability to use direct path names (or even browse the network in any sane fashion). Here's the fix:

Windows Registry Editor Version 5.00

; Restore the damned network icon in explorer 
@="Computers and Devices"

@="Computers and Devices"

Just import this reg file, reboot (3 times -- no more, and no less) while chanting the lyrics to a song by Radiohead (any song will do). For me, all is well. I'm going to go murder my friend now.


If none of the above works [UNC share not working but internet browsing works, Ping works etc]

(1) Use netsh -> Winsock context -> reset it
(2) If (1) doesn't work goto Run type -> ncpa.cpl.
From the applet select "IPV4" properties, if that is what you are trying to troubleshoot and then select "Client for Microsoft networks". Uninstall this and then reinstall this. Reboot.

[Always ensure you have the Administrator account password. I am saying this because you could be logged on via domain user acct which is part of Administrators]

Once system is up, open ncpa.cpl again, From the networking tab - Use Install option(button), select clients and you should find "Client for Microsoft networks", select that and install. Reboot and hope it works this time.

  • netsh winsock rest is the command.
    – E.V.I.L.
    Nov 10, 2016 at 22:03

Very strange...

I would first suggest you suspect some cached permission set via "remember my credentials" being stored for the browsing getting in the way - i.e. they are wrong u/pw combination.

Have a look at the control panel section

Control Panel\User Accounts\Credential Manager

See if something in there stands out as wrong, or clear anything related to the remove machines and try again.

  • The credential manager, I'm afraid, is completely empty. No luck there.
    – Fopedush
    Aug 16, 2011 at 5:52

I was facing the same issue when I tried to see how it goes for me,

all what I did, is :

[ net share ] on the remote machine to see if c$ is shared

then on my machine, typed :

[ net use /user:Administrator ]

That was exactly everything, then when I used \\remote\c$ it prompted me for the user name and password.

I really don't like solving things this way, but tell how it goes for you.

  • I'm not quite sure what you're getting at here. "net use /user:administrator" isn't valid syntax for the net command. Do you mean that I should be mounting the location as a network drive as administrator? If so, that's basically the same as the workaround I've already got. However, mounting the location as a network drive does not allow me to then browse to it using the \\UNC-Name syntax.
    – Fopedush
    Aug 19, 2011 at 20:53

I had the same problem you are all speaking of. I tried resetting DNS and re-installing Print and File Sharing. Nothing seemed to work. But I reset my CSC cache and restarted the PC and that worked. Here is the instructions for resetting CSC cache. HOPE IT HELPS!

Issue: Can browse to a network share using IP address but not when using Host Name.

Example: \\\c works --- \\Servername\c Does not work

To resolve this problem, re-initialize the cache of offline files. To do this, follow these steps:

  1. Click Start, type regedit in the Start Search box, and then press Enter.

Note If you are prompted for an administrator password or for confirmation, type the password or click Continue.

  1. Locate the following registry subkey, and then right-click it: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\CSC

  2. Point to New, and then click Key.

  3. Type Parameters in the box.

  4. Right-click Parameters, point to New, and then click DWORD (32-bit)Value.

  5. Type FormatDatabase, and then press Enter.

  6. Right-click FormatDatabase, and then click Modify.

  7. In the Value data box, type 1, and then click OK.

  8. Exit Registry Editor, and then restart the computer.

Note Make sure that files are synchronized before you add this registry entry. Otherwise, unsynchronized changes will be lost.


Add the line into hosts file and try again. It might be DNS magic. reliant

If you don't know the reliant's IP just command:

ping reliant

If you use the same share regularly you can create a batch file like this, here I do same on a laptop which one is not the member of the domain and forgets user/password seldomly:

net use \\reliant\c$  password /user:you /savecred
  • Or try \\\c$ instead...
    – Nime Cloud
    Aug 19, 2011 at 21:06
  • Same effect, still no love.
    – Fopedush
    Aug 19, 2011 at 21:12

I've run into the problem you're describing many times before and sometimes I've found that running the Network Setup Wizard on each computer to reconfigure your settings will fix the issue.

Remember to restart your computer after running the wizards.

  • Sorry, no luck here either.
    – Fopedush
    Aug 22, 2011 at 3:21

I had the same issue, but no solution works. I found another problem that was causing the same issue. Please check the following registry key:


That one was empty, but should contain the following data:

Category / REG_DWORD / 1

Name / REG_SZ / NetworkPlacesFolder

ParsingName / REG_SZ / ::{F02C1A0D-BE21-4350-88B0-7367FC96EF3C}

Hope that helps someone.



I solved my issue here, easy and simple. My case: Windows 10 didn't access the Lacie Nas Pro device, but I could access through the Dashboard, or from Mac or even Windows 7.

It was because SMB1 protocol is no longer acceptable for W10... So I just went to my dashboard (logged with user + password) > Device Manager > Customize / Settings. Down there, you must check for new NAS OS update and update the whole thing... vualá!

Good luck.


I resolved this way:

  1. cmd -> net use -> this gives you all the active connections.
  2. For each of the non-working connection: net use "<connection name>" /DELETE
  3. Start -> Credentials -> remove all of them
  4. TaskManager -> Kill all EXPLORER.EXE processes, and start a new EXPLORER.EXE
  5. Now you can re-map the network share as a drive.
  • Please note that the original question specified that mapping the network share as a drive is not an acceptable solution.
    – Fopedush
    Mar 6, 2018 at 22:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .