2

I am running Mac OS 10.6.8

I have mounted a network drive, whose file I need to watch. I was planning on using tail.

When I run the following:

tail -f /Volumes/Cache-A/TransferLog.txt 

I end up with a tail report that looks correct, however it does not update. (it is as if I had typed tail rather than tail -f except that the shell does not come back - I have to type Ctrl-C to get back to where I can type)

The Cache-A drive is a linux system, and I have confirmed that when I run the command

tail -f TransferLog.txt

it updates as expected.

Is there a reason why the OS X tail command is not updating properly? Is it because it is a network mounted drive rather than a local file? Would mounting via NFS help? (I cannot mount via AFP)

EDIT: Turns out I CAN mount via AFP, although the same issue is occurring. (I'm not so smart with wireshark - but I'll look that over as well)

  • Try checking with Wireshark whether the SMB server actually sends file change notifications, so that you'll know which side is the problem at. (NFS doesn't even have change notification, so don't bother with it.) – grawity Aug 15 '11 at 21:43

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.