I have two users logged on to my Mac OS X 10.5 system. When trying to reboot from one account, it tells me that other users are logged in and that I have to confirm the reboot with the credentials of an administrator.

Neither the credentials of the other logged in user nor any system administrators credentials are accepted.

What is wrong with my user accounts setup?



I did some further research and there seems to be a bug with the UI confirmation buttons. So the resolution is to hit enter instead of using the "reboot" buttons, as described in the apple problem faq here: http://support.apple.com/kb/TS2317?viewlocale=en_US

However, even when doing this with the root user, the sysadmin account, this does not work for me...

  • As a confirmation; with the sysadmin account - can you use sudo on the command line? – Chealion Aug 31 '09 at 15:45
  • No I cannot... When I want to make users admin, as the sysadmin, the setting in the dialog persists only until the next opening... Going to reinstall OS X in a minute... – raoulsson Aug 31 '09 at 18:28
  • If you can not use sudo - you're not on the /etc/sudoers file meaning you're not recognized as an actual administrator of the computer. – Chealion Sep 1 '09 at 0:43
  • 1
    I tried to edit that file. Of course it didn't let me. I opened the admin account, set password with the install DVD. My main account used to be admin but not anymore... Reinstalling now... – raoulsson Sep 1 '09 at 9:29

Moving my comments into a proper answer:

The reason you can't log anyone out is that none of your users are actually administrators on the computer. You can check in the Terminal by looking at the /etc/sudoers file or attempting to run sudo -s. Additionally it should state that your account is Standard in the Accounts Preference Pane in System Preferences.

Reinstalling Mac OS X is one method, the other is to enable the root user to use the Account Preference Pane to set one of your users as an administrator again.


Does shutdown command work for you?

If so, you can use it as a workaround. Add it to sudoers file (so that admin password is not needed) and create script that launches it automatically. This way you'll be able to force shutdown with a click of an icon.


Have you tried to open Terminal.app and type in:

shutdown -r now


shutdown - is the command to turn off -r - is the flag to reboot now - is when you want to send the signal

This should force logout everyone else.

  • Yes, gives me "shutdown: NOT super-user" – raoulsson Sep 2 '09 at 16:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.