This Apple question contains the text

what is this key? ⎋

Which looks like this to me in Google Chrome:

enter image description here

Why is that Unicode character, or others like it, undisplayable in Google Chrome on Windows 7?

  • It looks like a box to me... In any case, double posting is frowned upon.
    – soandos
    Aug 16 '11 at 17:46
  • 3
    @soandos what other post are you talking about? also, it isn't supposed to be a box. that's why I'm asking the question. Someone asked a question on askdifferent and typed a unicode character there, but on my install of Chrome I see the generic box. Aug 16 '11 at 17:52
  • 3
    As do I... It appears it is not an issue with your chrome install, it is for all chromes. FF recognizes it fine. Chrome cannot even recognize it as a Unicode charachter (I don't think).
    – soandos
    Aug 16 '11 at 17:57
  • Interestingly, Chromium on Ubuntu does just fine.
    – Kibbee
    Aug 20 '11 at 1:02
  • @soandos Works fine for me with Google Chrome (12.0.742.112) on Ubuntu 11.04 (Natty). Aug 20 '11 at 2:49

I'm assuming it's a font substitution issue.

The browsers are encountering the problem of "The selected glyph is not in the specified font". There are two directions you can go from here: you can either pull the equivalent glyph out of another font (which will often look broken but it may not be clear why to the user) or just display a character-not-found placeholder (which will always look broken, but at least obviously so).

I imagine Firefox and Opera recognise that the glyph being requested is a symbol that is safe to pull from another font, while the remaining browsers are being conservative and just showing the "Uh... dunno" glyph.

  • I believe Chrome and Safari both use Windows GDI for text rendering on Windows. IE9 uses DirectWrite which appears to have the same behavior as GDI in this case. Aug 20 '11 at 0:35
  • Interesting: You get the same result if you paste it into the address bar.
    – xpda
    Aug 20 '11 at 2:08
  • @xpda you're right; the character works in the address bar and the body on Firefox, and does not work in either place in Chrome. Fascinating. Aug 20 '11 at 2:41
  • 5
    Sounds about right: Chrome and Firefox both use Uniscribe to render text in-browser, and Uniscribe just returns an error code to the calling application when a particular character can't be found in the current font. It's up to the application to decide whether Uniscribe should then use font fallback to find a substitution, or whether it should just render the box glyph. Chrome is one of the browsers that just says "Whatever, I don't care. Box is fine." Aug 20 '11 at 3:10

Interesting. It's not just Chrome -- you might well ask why any of the following browsers can't display it on Windows 7:

enter image description here

From top to bottom:

  • Firefox (y)
  • IE9 (n)
  • Chrome (n)
  • Opera (y)
  • Safari (n)

Therefore, Firefox and Opera can display this unicode character in Windows 7, but the other browsers cannot.

what is this key? ⎋

  • For what is worth, that key is "ESC" in Mac OS X. Aug 20 '11 at 0:28
  • @jjn it's a partial answer, which is generally allowed Aug 20 '11 at 1:08
  • Noted. (Comment withdrawn.)
    – jjnguy
    Aug 20 '11 at 1:10
  • How alike browsers are this days... :)
    – balexandre
    Aug 20 '11 at 1:12
  • 2
    Chrome 13.0.782.107/Linux: ok Aug 20 '11 at 10:13

The question asking "Why is that Unicode character, [...] undisplayable in Google Chrome on Windows 7?" is the

That particular character is simply a unicode codepoint which is an arbitrary number. There are a lot of unicode codepoints that do not have an 'official' symbol. Even if they do have a symbol, it is not necessarily the case that your font has a symbol for that codepoint. If you choose a different font, you may end up with a different symbol.

I looked at the CSS for the page and it shows this character displaying in Arial (plus a bunch of other fonts that do not matter). Windows comes with Arial so it should always pick up that font first. It looks like Arial does not have a symbol for that unicode codepoint. Anytime you do not have a glyph for a codepoint, it puts in some form of a box indicating there is no glyph (as others have indicated).

The bigger question is, what exactly is Firefox or the other browsers doing where it works on Windows. I looked at the other fonts listed in the CSS (I thought it may be falling back on the next CSS font) but they also do not have a glyph for that codepoint. One possibility is that Firefox actually ships with its own fonts.

Digging into firefox, I did notice some fonts for math symbols here: 'C:\Program Files (x86)\Mozilla Firefox\res\fonts'. Perhaps this is where it is coming from.


I know this is a bit of an old question, but for those who are freshly Google'ing this, I have a solution that worked in 2013. First, you must confirm that you have a font installed in your Windows 7 PC that can render the font:


Assuming that at least one font in the Local Font List renders this:


If not, then install a couple of "catch all" Unicode fonts: Code2000 and Symbola

Once you have a font that'll render the symbol, you can try the browser test page:


Chrome 28.0.1500.95 (and probably all recent releases) performs font substitution ... mostly.

For whatever reason, even with fonts that render U+1F3C1 correctly installed, Chrome 28.0 won't display this Unicode character: 🏁. Firefox works beautifully. Go figure.

  • Dave

As per The Absolute Minimum Every Software Developer Absolutely, Positively Must Know About Unicode and Character Sets (No Excuses!) by Joel Spolsky, "If there's no equivalent for the Unicode code point you're trying to represent in the encoding you're trying to represent it in, you usually get a little question mark: ? or, if you're really good, a box."

Im running Chromium 13.0.782.112 on Archlinux and my default encoding is en_US.UTF-8 -- the charcter displays fine on the originally linked page.

  • 2
    that's fine, but I don't think the question was about the box, but why some browsers can display this particular character and others cannot. Aug 20 '11 at 0:43
  • @Jeff Atwood, agreed - if anything, my answer provides more supportive evidence re the typographical issue; read here. I can't tell you the default font as I'm not in front of my machine.
    – wulfgarpro
    Aug 25 '11 at 23:59

The actual answer: It's because there's a bug in Chrome that borks Windows 7 (and higher?) unicode font rendering.

The issue is here, with all the gory details: https://crbug.com/42984 (star it and maybe somebody will notice it?)

More analysis and a possible workaround can be found here: http://gschoppe.com/uncategorized/fixing-unicode-support-in-google-chrome/ .


Firefox 45.0 on my GNU/Linux LFS 7.9 didn't show the Unicode glyph mentioned in question, also didn't display other glyphs like greek etc.

However after downloading Symbola font from here and then:

~$ unzip Downloads/symbola.zip -d Downloads
~$ mv Downloads/Symbola/Symbola_hint.ttf .fonts
~$ fc-cache

Firefox now shows the glyph in question, and also displays other glyphs.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.