6

I have both the "stop websites from storing local data" and the "block all third party cookies without exception" settings enabled in Chrome 12 (I'm not sure what the exact names of these settings are in english as I run Chrome with swedish localization). I do however have two problems.

My first problem is that when I'm visiting one of my local news paper's site (and surely other), cookies from www.facebook.com is allowed for some reason. I suspect that the reason is that I have added an exception to the www.facebook.com domain but as the setting "block all third party cookies without exception" implies, that shouldn't matter.

My second problem is that if I check what cookies are stored on my computer after browsing for a while, I have tons of cookies that are not on my white list. Primarily from ad services.

My expectations from enabling the above mentioned settings was that only cookies that fulfill the two folling requirements would be accepted:

  • the cookies must be from the domain in my address bar
  • the cookies must be from a domain on my whitelist

Apparently this isn't the case. The question is, have I completely misunderstood the settings or is this a bug? And, either way, is there a way to accomplish my desired behavior?

5

type about:flags

into the url bar and hit enter, then enable "Block all third-party cookies"

enter image description here

  • I assume you mean the option "block reading of all third party cookies" (or whatever it is called in the english version of Chrome)? That actually worked! – David Nordvall Aug 18 '11 at 8:03
  • That is the end result but no, it actually says what I posted, see image I added to my answer. – Moab Aug 18 '11 at 15:02
  • Ok, that's the same option. In Swedish, it basically says what I wrote in my original comment (only in Swedish ;-). – David Nordvall Aug 24 '11 at 9:36
  • 1
    I don't seem to find this setting in Chrome mobile 39.0 Did they change something? – user4085 Jan 11 '15 at 13:37
  • mobile versions of chrome are very different from pc versions. – Moab Jan 24 '15 at 14:22
6

In the current Chrome (v56, checked 2/23/2017) it is no longer in about:flags, but moved to the main UI.

  1. Click on the triple-dots to open the menu (top right)
  2. Click Settings
  3. Scroll all the way down to the link "Show advanced settings" and click it
  4. In the Privacy section click the Content Settings button
  5. Under the Cookies section there is a checkbox for Block third-party cookies and site data. Make sure this one is checked to prevent third-party sites from setting cookies.

After enabling this is probably also a good time to delete all existing cookies.

  • 1
    This is the right answer as of 2018, the top answer doesn't work. Without this setting, nothing is private on the internet. Just make it so hard, that most users can't find these settings. – mosh Jan 14 '18 at 15:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.