3

I see stuff like this now anytime someone changes their font or pastes a link.

<im:html xmlns:im='http://jabber.org/protocol/xhtml-im'><xht:body xmlns:xht='http://www.w3.org/1999/xhtml'><xht:p>for example, <xht:a href='http://itunes.apple.com/us/app/office-jerk/id423593206?mt=8'>http://itunes.apple.com/us/app/office-jerk/id423593206?mt=8</xht:a></xht:p></xht:body></im:html>

Not sure why it's not being parsed.

Any ideas on how to fix this?

UPDATE: Fixed in Adium 1.4.3rc1. See bug ticket.

3
  • I have a 10.6 machine, receiving this stuff from my parents using 10.5 Noticed just yesterday, never seen this before. Quite annoying..
    – user94831
    Commented Aug 19, 2011 at 17:05
  • Complaining about it on this site won't help. The Adium guys are aware of the issue and a fix is probably being worked on right now.
    – Daniel Beck
    Commented Aug 19, 2011 at 17:15
  • This issue was fixed with a recent update. <3
    – bobber205
    Commented Aug 23, 2011 at 16:00

1 Answer 1

6

This appears to an issue with OS X Lion iChat clients sending XHTML-IM formatted messages. In my experience it happens sporadically.

A ticket has been filed in the Adium issue tracker against it.

Unable to find a fix thus far.

4
  • 1
    +1 for link to the bug ticket. This is not limited to Lion iChat; it's happening on IMs sent from other clients as well.
    – JCotton
    Commented Aug 18, 2011 at 18:34
  • @JCotton, I'm not following: this is happening to people who USE adium on the receiving side? Commented Aug 18, 2011 at 22:51
  • Yes the XML envelope wraps the response received by Adium users. Senders don't notice anything. It's Adium users on the receiving side with at least versions 1.4.2 and 1.4.3b2. It happens on all IMs too, not just links and font changes.
    – JCotton
    Commented Aug 19, 2011 at 15:55
  • I am seeing it just from pidgin users.
    – bobber205
    Commented Aug 19, 2011 at 21:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .