I've got a WRT54GS that I've loaded the current version of Tomato onto. I entered static DHCP addresses in for the devices on my network, released and renewed the address on my desktop and tried to ping another computer. All I got was The request could not find host blah. Please check the name and try again. Now, I verified that my desktop and the target machine I'm trying to ping have both received their proper static DHCP lease and that their DNS server is the IP address of my router. What am I missing?

  • Are the machines firewalled? – Breakthrough Sep 3 '09 at 0:54
  • Good question. I'll have to check. – jasonh Sep 3 '09 at 21:29
  • So, the machines are firewalled with Windows Firewall, but it's kind of intermittent. Some of the time the machines can ping each other by host name, other times not. Interestingly, my Macbook has absolutely no trouble with host names on the network. Any new ideas? – jasonh Nov 20 '09 at 22:47
  • probably you should reformulate your question, because I believe it's windows issue, not router/DNS – Davide Nov 20 '09 at 22:54
  • What exactly are you trying to accomplish? – AnonJr Nov 21 '09 at 0:06

I would start by making sure that the settings are the same on every computer (have to rule it out)... then on each machine, right click on the network interface settings and do properties, double click on IPv4, then advanced.

From here, I would click on the DNS tab and manualy add the server in the top list then select the option "Append these DNS suffixes (in order):" and choose something such as .local or .mynetwork then tick the bottom two options.

Restart all machines after making these changes and go to the command prompt and type ipconfig /renew followed by ipconfig /registerdns

Next, at the command prompt, type "Nslookup" and just try the name of one or two machines and see what happens.

If you are still getting no where, check DNS settings on the router, it sounds like it is not allowing other machines to register / is a caching DNS server for the internet ONLY, if it does work - cool.

If this doesn't help, you may be best off just using hosts files or using a different firmware - but, hopefully it has helped.

Edit - Also, Just thought - Remember to check that ICMP Echo is allowed on the Windows Firewall!

| improve this answer | |
  • 2
    The nslookup is what did it. Windows reported that the DNS server (my Tomato router) did not know the hostname for one of the Static DHCP entries I put in. So I did a bit of Googling and found out that you have to assign a domain name to the router and as soon as I did that, I can now ping by host name! Thanks! – jasonh Nov 27 '09 at 20:30
  • @jasonh - your comment solved my DHCP problem also; as soon as I added the domain name everything fell into place. It seems to me that it would be good to have this set to some default. – Geoff Jun 7 '14 at 20:33

Can you ping each machine via IP? If so, then edit your hosts file so that IP resolution will map correctly. The file can be found in your %windows%\system32\drivers\etc folder. Use any text editor, DO NOT change the extension.

good luck.

| improve this answer | |
  • Yes, I can ping each machine's IP without issue. I do not want to edit hosts to accomplish something it should be able to do automatically. Thanks for the suggestion though. – jasonh Nov 21 '09 at 2:08

their DNS server is the IP address of my router

The DNS server should more than likely not be the address of your router.

| improve this answer | |
  • 3
    no, this is a perfectly sane way to configure it. the router acts as a caching DNS for the LAN. – quack quixote Nov 21 '09 at 0:29
  • I don't see anything particularly sane about expecting router firmware to replace BIND, but to each his own. – Hasaan Chop Nov 21 '09 at 0:34
  • dnsmasq isn't exactly a BIND replacement... but then if your home/SOHO network needs BIND, you're already running your own in-house DNS. – quack quixote Nov 21 '09 at 0:53

If you're trying to connect via Remote Desktop, check and see if all of your machines are in the same workgroup. (I'm assuming based on your question that you're not running a domain at home - feel free to correct me if I'm wrong)

At least in XP networks (you don't state what your computers are running...) I've seen instances where that makes a difference.

| improve this answer | |
  • Thanks, but they're all in the same workgroup. I used to run a domain and everything worked perfectly then, but not now. – jasonh Nov 22 '09 at 2:23

I have this exact configuration working on my network at home, its very convenient. One setting that may make a big difference is in the "Advanced" settings under "DHCP/DNS" turn on the "Use Internal Caching DNS Forwarder." That will enable the DNS server on your router which will also deliver your router's IP as the DNS server in all DHCP requests. With the DNS server on, you should be able to now lookup all of the hosts on your network. I am even able to lookup the hosts which get a Dynamic IP address by hostname using this configuration.

| improve this answer | |
  • sounds like this is already configured (he mentions the router's IP as DHCP-assigned DNS server) ... tho it's good to double-check. – quack quixote Nov 22 '09 at 18:04

It's a very long time I do not fiddle with router's firmware, but here are my only two ideas:

  • it could be a DNSmasq configuration problem of . It would be useful if you would post your dnsmasq.conf file, maybe. That file is heavily commented, so it should be easy for you to see what options might play a role in your problem.

  • it could be a problem with the host names (if they have a dot in it they are looked up on the internet instead of being retrived from the router).

Additional information that you might consider providing:

  • Windows version you are using
  • Tomato version you are using
  • Host names of your local machines

Hope this helps!

| improve this answer | |

Try cleaning the ARP cache on both machines (a reboot should suffice) and see what happens.

| improve this answer | |

I need to check the facts.

You have replaced firmware in the router. You have given both computers DHCP assigned but static IPs using the router. You can ping each machine by IP address. You can sometimes ping by computer name but not always. The macbook does not have the problem with hostnames.

If so, this is about were windows resolves the computers hostname into an IP address.
Since it is not using NetBIOS to get the IP, it will use the hostname to resolve IP, it is first going to check itself, then the hosts file and then the DNS server to do this.

So a problem with the DNS server results? The fact that it works sometimes and not others is problematic.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.