I want to set up an rsync command as a cron job, so I need to find a way to supply my server password automatically to rsync.

Currently I have a shell script that looks like this:

rsync *.rss me@myserver.com:/home/dir --password-file ~/rsync.password

The rsync.password file just contains my password.

However, when I run the script, I get:

The --password-file option may only be used when accessing an rsync daemon.
rsync error: syntax or usage error (code 1) at main.c(1241) [sender=3.0.7]

Could anyone let me know how to fix this, so I can start to run the shell script as a cron job?


What you really want to do is look at setting up public keys between the servers so they 'trust' each other and passwords are not needed.

Have a read here:



  • That links do not solve the problem when executing under cron.daily, it runs without password in a Termina – Albert Català Jun 17 '16 at 19:24

Some times there is need to rsync without ssh involved, especially if rsync is running as a server on one side. In this case I wrote instructions, how to give rsync password from command line.

This is very good for scripting: rsync-without-prompt-for-password

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.