I can only see 1.6.0 (32 and 64bit) on the Java Preferences dialog, and I need it to run applications using Java 1.5.0

  • why would you run java applications using an older JVM,while the latest performs perfectly ? – Mahmoud Hossam Aug 31 '09 at 0:21
  • 1
    Perhaps he has some crazy legacy apps or requirements to meet. – Josh Hunt Aug 31 '09 at 1:34

You can install the old Leopard version of Java 1.5.0, and it runs perfectly fine on Snow Leopard. Instructions are here.

| improve this answer | |

Snow Leopard only has Java 1.6, but it is compatible with older Java versions, and you can even compile for older Java versions on the newest version, you just need to specify the option if you are using javac (add '-target 1.5').

For example, the Java in the 1.5.0 framework directory is really 1.6.0:

$ /System/Library/Frameworks/JavaVM.framework/Versions/1.5.0/Home/bin/java -version
java version "1.6.0_15"
Java(TM) SE Runtime Environment (build 1.6.0_15-b03-219)
Java HotSpot(TM) Client VM (build 14.1-b02-90, mixed mode)

If you are trying to get an application to run and it is failing because it doesn't handle the Java versions correctly, so either contact the program vendor if able, or post some more information about the application to hopefully get it working.

| improve this answer | |
  • After upgrading to Snow Leopard, even though Leopard recognized all my different previous versions of Java on the Java Preferences dialog. The Snow Leopard Java Preferences dialog seems to only care about 1.6. Even though my application's Info.Plist is meant to run using 1.5.0, Snow Leopard is launching with 1.6.0 instead. Look, all my JVMs are still there: gubatrons-macbook-pro:Versions gubatron$ ls total 48 1.3 -> 1.3.1 1.3.1 1.5 -> CurrentJDK 1.5.0 -> CurrentJDK 1.6 -> 1.6.0 1.6.0 A Current -> A CurrentJDK -> 1.6 – Angel Aug 31 '09 at 2:08
  • Notice on your output that 1.5 and 1.5.0 are actually symbolic links to the CurrentJDK, which is a symbolic link to 1.6. The only thing in the 1.3 directories is some libappshell.dylib library. – Lara Dougan Aug 31 '09 at 2:55

I've updated my version to 1.6.0_20 yesterday and had to install it all over again.

This time I followed the instructions detailed here and worked perfectly:



  1. Download Java update 4
  2. Download Pacifist
  3. Delete links 1.5 and 1.5.0 on existing installation
  4. Use pacifist to extract those file in the default location

Detailed information in the link

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy