I have an external HD with usb 3.0 support and have installed a PCI card to add two usb 3.0 ports to my pc. I am running windows 7.

When I connect the hard disk I receive a notification about usb speed: "your device can perform faster" ... I have installed the provided drivers (for the so called NEC Electronics USB 3.0 Host controller) and the device is reported to be "properly working". The driver version is and the firmware version is 3025 (as reported by the provided utility).

Is the message reliable? How can I fix it (achieving the usb 3.0 speed obviously :-) )?

  • Are you sure that your external hard drive is USB 3.0?
    – Diogo
    Aug 22, 2011 at 16:37
  • 1
    were you using a USB 3.0 compliant cable?
    – Keltari
    Aug 22, 2011 at 16:50
  • Did you check the BIOS ? Some have Enhanced Controller (EC) options, ensure it is enabled on your machine.
    – Daniel
    Aug 22, 2011 at 16:52
  • 1
    PCI or PCIe? PCI can't handle USB 3.0's full speed Aug 22, 2011 at 17:18
  • 1
    Try benchmarking the HDD and tell us what transfer speeds you're getting. Also, @Luke, the card he linked to above is indeed a PCIe USB controller. Aug 22, 2011 at 18:49

2 Answers 2


In the thread USB 3.0 bracket Low 2.0 Speeds the problem was electrical interference.
I suppose that at USB 3 speeds everything must be perfect.
The thread mentions "ferrite core IN the bracket connector", which is unfamiliar to me.
Does your cable have a ferrite bead ?
(I would maybe try a better-quality cable.)


The blog “This Device Can Perform Faster” USB 3.0 Pop-up lists all the possibilities :

  1. Temperamental connections and devices
    Try disconnecting and reconnecting. Since USB 3.0 uses additional contacts, it’s important to achieve a tight connection
  2. Drivers
    CNET offers an excellent resource for free drivers.
  3. Overclocking
    The DRAM for the motherboard that you set to a certain frequency for performance may be incompatible with your port or USB 3.0 card because it affects the PCI bus. By reducing the speed of your front side bus (FSB), 3.0 can operate as intended.
    See also this thread, where down-tuning the FSB off by 20MHz made it start working.
  • 1
    That was for a connector that was extended to a bracket with interference being picked up by the extension inside the case. His connectors are not extended and there's no reason he should have this particular problem. Aug 25, 2011 at 21:48
  • @Francesco: I added some more possibilities.
    – harrymc
    Aug 26, 2011 at 6:53
  • Since I removed and replugged the cable for taking the photo I have not receveid the message again. It appears that the cable was not well plugged but worked properly nonetheless (although not achieving usb 3 speed). I was sure to have cheked it but.. that's what happened. Not believing to what I was seeing, I have tried plugging the cable in an USB 2.0 port and the message popped up again, so it's not that i turned off notification. Never seen such a thing.
    – Francesco
    Aug 26, 2011 at 12:30
  • All is well that ends well. Just to remark that accepting the answer and awarding the bounty are separate actions.
    – harrymc
    Aug 26, 2011 at 13:34
  • 1
    @Francesco I have seen the same thing happen to me. It appears that it reverts to USB2.0 speeds if the connection isn't just right. Perhaps USB 2.0 is more tolerant of noise in the signal than USB 3.0 is. Aug 26, 2011 at 17:35

My bet is that you connected two USB 3.0 devices to each other with a USB 2.0 cable. You need a SuperSpeed cable that has the extra 4 connectors.


  • 1
    it is interesting that both you and @harrymc thought about the cable. I am using the one which was provided by Verbatim. It reports usb 3.0 on it, I shot a photo of it. The brand is BizLink.
    – Francesco
    Aug 25, 2011 at 22:55
  • That is a USB 3.0 cable. Unless it's damaged, it should give you USB 3.0 speeds. Aug 25, 2011 at 23:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .