I've got a Visual Studio 2010 project with some post-build commands to neatly package up all the dlls etc that the project needs, zip them all, and then copy the zip to a network drive for distribution. (Aside: I am aware of the various "correct" ways of distributing applications with Visual Studio but due to the weird / esoteric nature of my application they are not appropriate)

I moved to another computer, extracted, and ran, and found that it was missing a dll. I went to look at my build output in VS2010, and found this line: The system cannot find the file specified. C:\My Documents\Visual Studio 2010\Projects\SolutionName\ProjectName\File.dll

Confusing, as I can see that the file is right there in Windows Explorer. I decided to try manually copying the file from the command line, and I got the same error message. The file also does not show up when I use "dir", even though I can see the file plainly in Windows Explorer. Even MORE strangely, when I tried to copy the file, it was suggested by tab completion!

No clue what is going on here. Any ideas?

edit: After following up on an answer, I discovered another odd thing about this file: the "Hidden" check box under the file's properties is grayed out. Why would this be?

second edit: Well, I uploaded the file to the internet then downloaded it again and that fixed the problem. Still very confused as to why this even happened in the first place.

  • What happens when you do dir /a:sh in the directory? – Breakthrough Aug 22 '11 at 21:47
  • C:\My Documents\Visual Studio 2010\Projects\SolutionName\ProjectName>dir /a:sh Volume in drive C has no label. Volume Serial Number is 24A7-5D52 Directory of C:\My Documents\Visual Studio 2010\Projects\SolutionName\ProjectName File Not Found – Alexander Questioning Bresee Aug 22 '11 at 21:50
  • Is it possible that this is some kind of symlink that explorer supports but cmd.exe does not? – Fopedush Aug 22 '11 at 22:45
  • I don't think so. I copied the file there myself. I didn't make any kind of symlink. – Alexander Questioning Bresee Aug 23 '11 at 13:11

Couple thoughts:

  • The file is marked as hidden, but you have 'show hidden files' turned on in Explorer.
  • You have disk corruption (try a chkdsk).
| improve this answer | |
  • the file is not hidden (doesn't appear 'faded out' in Explorer, and under 'Properties' the 'Hidden' box is unchecked [in fact it is grayed out]). As for disk corruption -- I not an hour ago ran chkdsk for an unrelated issue and it came up clean. – Alexander Questioning Bresee Aug 22 '11 at 21:52
  • Why would the "Hidden" box be grayed out??? – Alexander Questioning Bresee Aug 22 '11 at 21:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.