For starters I'm running a 64bit Version of Windows 7. I'm also dual-booting 64bit Ubuntu 10.04 (if it matters). However, for this I'm trying to get this working on the Windows 7 side of things.

I downloaded the BackTrack 5 32bit GNOME .iso file (BT5-GNOME-32.iso) to my USB stick fine and made a VM on VMware Player. I set the OS as "Other Linux 2.6.x kernel" (if it matters). However, when I go to play my VM I get the following screen.

BT5 VMware

I know I'm supposed to type Startx to launch the GUI. However, nothing happens; it's completely unresponsive (and yes keyboard focus is routed to the VM). There is no response, the cursor doesn't even blink. Any ideas what I'm doing improperly/not doing. If any more info is required for a proper diagnosis, leave a comment. Thanks!

Edit :

Some of the settings.

enter image description here

  • The ISO that you are running is not backtrack 5. – soandos Aug 23 '11 at 5:46
  • Are you getting that just from the "BT5-GNOME-32.iso" file name? Elaborate if possible. – RectangleTangle Aug 23 '11 at 6:23
  • @soandos - What makes you think that it's not BT5? That's exactly what it looks like minus the boot: prompt. – Joe Internet Aug 23 '11 at 6:34
  • Try booting the VM directly from the iso file - add it to the virtual cd drive. If it boots, you know that it's an issue somewhere with the USB stick. – Joe Internet Aug 23 '11 at 6:37
  • 1
    What I meant is that BackTrack already offers a built VM machine (since version 4 IIRC). See Mokubai's answer, that's what I meant. – m0skit0 Aug 23 '11 at 8:32

BackTrack 5 appears to already have a VMWare image available for download, which should be configured for you already.

Make sure that your when you go to the download page the options selected look like this:

enter image description here

You will also need 7-Zip in order to extract the .7z file that it downloads, but apart from that you should be able to follow the tutorial as on this site which I shall copy here for completeness.

  1. First unzip the file (using 7-zip). The result is a folder called: BackTrack4-Final (may be different as you are now downloading backtrack-5)

  2. Move BackTrack4-Final and its contents to the Virtual Machines folder created for you by VMware when you first installed it. Under Windows 7 it is located at:
    C:\Users{Your User Name}\Documents\Virtual Machines

  3. Run VMware Workstation

  4. From the menu bar, select File –> Open and navigate to the BackTrack4-Final folder. Inside the folder you should find: BackTrack4-Final.vmx. Open it.

  5. Now that the image is loaded into your VMware Desktop, click: Power on this virtual machine.

    Most likely, you will get the following dialog:
    “This virtual machine may have been moved or copied.
    In order to configure certain management and networking features, VMware Workstation needs to know if you moved this virtual machine or if you copied it.”

  6. Choose "I copied it" and proceed.

  7. If everything goes well, and it should, BackTrack will ask you to log in. The username will be root and the password is toor.

  8. Once logged in as a root, type startx to run the graphical interface.

  9. The internet/network is not connected by default in BackTrack, to start it run the Konsole and enter the start-network command.

  10. If that did not work, open Wicd manager (K menu –> Internet –> Wicd manager) and click Connect. The status bar should show something like:

    Connected to wired network (IP: xxx.xxx.xxx.xxx)

  • I'm going to try this when the download is done. – RectangleTangle Aug 23 '11 at 8:39
  • Just tried this; everything went smooth as silk! – RectangleTangle Aug 23 '11 at 19:52

Okay, so I am very excited to share the SOLUTION with you if you still need it. I think that in order to run guest operating system in VMWare on a host OS, the version of guest must be lesser than that of the host. Otherwise, the system would throw an error of incompatibility. For instance, I started out trying to install bt5 r2 for 64 bit OS on my win 7 host OS in VMWare player ~4.0.4. I got the incompatibility, x86-icpu, blab blah incompatibility error. So then, later during reinstalling, the system informed me that I cannot install a 64 bit ubuntu, guest OS on my win7 64 bit, host OS.

Well then, I decided that the solution would be to install a smaller bit version, which in my case, is bt5 r2 32 bit. AND THIS SOLVED THE PROBLEM. IT IS WORKING LIKE MAGIC!!! NO NEED FOR INTEL VIRTUAL /EP5 or any of those processors mentioned.


  • Please avoid using all caps in your answers. – bwDraco Oct 11 '12 at 5:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.