Installing the flash player plugin on a Linux PC has proven to be a true nightmare every time I've tried it. This time I'm on Fedora 15 x64 on a Notebook computer. I have downloaded and installed Chrome 13.0.782.112, which now resides in /opt/google/chrome.

Googling how to install the flash player plugin, I'm told that the stable release of Google Chrome has had flash player built in since some time in 2010, and that I can enable it by visiting chrome://plugins. Not surprisingly, the plugin is not there.

So I download the flash player plugin, libflashplayer.so, by installing the .rpm package from the adobe flash player download page. I try copying it into /opt/google/chrome without success. I try placing it into /opt/google/chrome/plugins without success. i tried creating a symbolic link from /opt/google/chrome/libflashplayer.so to /usr/lib/flash-plugin/libflashplayer.so (Most of the plugins shown in chrome://plugins are symbolic links placed in the chrome folder) but still no success. Between every attempt I exited Chrome from the wrench icon menu and restarting it, visiting youtube.

I'm having no luck installing the plugin, and Googling for help only slaps me in the face with "it's pre-installed in all stable versions since 2010".

Thanks for any help on the matter.

Edit: I've now specified that I'm using Fedora x64. Thanks for pointing it out

  • I suppose you've forgot to mention it's for x64, right? Aug 23, 2011 at 14:04
  • Yes, quite right
    – Hubro
    Aug 23, 2011 at 14:21
  • Have you tried one of these tricks? : google.com/support/forum/p/Chrome/… Aug 23, 2011 at 14:34
  • I don't know if this helps, but I'm running 12.x series Chrome on Ubuntu 11.04, which is of course x64, and Flash just works. However, I do have this installed for FF, so technically Chrome might use it, too: flashplugin-installer Adobe Flash Player plugin installer.
    – Zds
    Aug 23, 2011 at 14:34
  • 1
    Another trick is to install x32 versions of both Chrome and Flash player. This is how I solved this problem. Aug 23, 2011 at 14:36

1 Answer 1


The flash you downloaded is probably a 32-bit flash if you got a packaged version.

Download the 64-bit beta from Adobe.

Unpack libflashplayer.so to /opt/google/chrome/plugins and merge the usr directory with your filesystem's usr directory.

  • Chrome also scans /usr/lib64/mozilla/plugins. By dropping it in there both Firefox and Chrome would pick it up. Aug 23, 2011 at 15:12
  • 1
    @Chad True, but I kinda like keeping flash away from my beloved Firefox. It's awesomer than my model airplane and I plan to keep it that way.
    – digitxp
    Aug 23, 2011 at 15:14
  • Thanks a lot. Making a chrome/plugins folder did the trick
    – Hubro
    Aug 26, 2011 at 13:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.