I'm trying to run commands such as "cmd.exe", "appwiz.cpl" etc by typing it in the Search box of the Start Menu in Windows 7 (x86). I'm able to do this just fine in Vista. After typing in "cmd" I notice that I see a link to "Programs" in the start menu so it seems that "cmd" is being recognized but when I click on "Programs" link which is shown,I get the following message.

"These files can't be opened. Your internet security settings prevented one or more files from being opened"

P.S. - I'm not looking for enabling the "Run" command to show in the Start Menu

I know I could use WinKey + R but I was hoping to get the same behavior as in Vista so that I can run any program from the search box. I would be a shame if that option is not available in Win-7.

  • 3
    I beleave you would appreciate the hotkey WINKEY+R. – Havenard Aug 31 '09 at 4:38

I managed to solve this while keeping my user profile intact. Only a minor change to the registry was required. Blowing away the user profile must have the same effect:

  1. End Task on EXPLORER.EXE from Task Manager.
  2. Start the Registry Editor
  3. Look for the following key:
  4. Rename the key so it looks like the following:
  5. From Task Manager click on File | New Task (Run) and type EXPLORER.EXE and hit return.
  6. Now try your search from the Start Menu again.

Restoring all the %profile%\*ntuser* files should also have a similar effect (*ntuser* files are where the user registry settings are stored.) Unfortunately my system restore attempt failed and I did not have any previous versions.

via sevenforums.com

For those who don't understand the original problem: The Start menu quick search results are messed up...

alt text

... and this error message appears after clicking an item from the results above.

alt text

| improve this answer | |

When I type "cmd" in the Start Menu on Win7, I get "cmd.exe" and not "Programs".

So I don't think that "cmd" is being recognized on your machine.

| improve this answer | |

I finally solved this by blowing away my profile and creating a new user. This seems to have fixed the problem

| improve this answer | |

OK, I managed solving this without destroying the profile:

I did a search for the key that I was supposed to delete/rename (I couldn't find it in the specified locations), and located it under a WoW64-something-or-other node in the registry. I can't recall what it was called, but just search for {ef87b4cb from the top of the registry.

I exported the FolderTypes branch, changed the HKEY_* to HKEY_LOCAL_USER in my favorite text editor and imported all the folder types to my current user.

Darn... it still didn't work, so plan-B was to now do what the guides say, and rename the TopViews->{0000* key to *.bck. Still no luck.

Out of frustration I changed the sequence of events, by first killing explorer.exe, then renaming the .bck back to the "live" key, restarted explorer.exe and BINGO!

Hope this helps someone else, I may have just been lucky - there's nothing scientific and repeatable about Windows' registry ;-)

| improve this answer | |

Alternate Solution for same error message.


Microsoft Downloads - in my case those from the Microsoft Update Catalog,

but it has also been reported those from Web Update,

Microsoft Downloads Create file / path names in Windows 7 64 bit greater than the maximum allowed within Windows 7 64bit. Note you cannot create over length path names manually in Windows 7.

The maximum is 260 characters including 3 character drive designation plus 1 character terminating character.

The maximum is 256 not counting the drive designator ( i.e. C:\ ) and also not including the terminating character at the end. So the entire directory path plus the file name should be less than or equal to 256 characters. Excluding the three ( 3) character drive designator "C:\" from the 256.

In my case the path downloaded from Microsoft by Microsoft software was greater than 270 bytes in several cases.

The result was the same error.

These files can't be opened.

Your Internet Security settings prevented one or more files from being opened.

Either of the following solutions worked:

Copy the file to a much shorter directory.


Rename the file in place so that the entire path, including the file name, is less than 256 characters.

Obviously in these cases the error message is misleading.

It appears this may be a default error message that pops up when the real error is not identified.

| improve this answer | |

First I would NOT recomend clicking Run As Administrator at this point. Mostly because Windosws 7 is telling you that the executable command.exe was installed from the internet. This could indicate virus activity, which is a possibility since windows 7 does not ship with antivirus software installed, and most existing AV software must be uninstalled prior to upgrading and the Win 7 version installed after the install is complete. This leaves your system vulnerable to attack -- a silent one since no AV is installed.

Run a Virus scan against the executable first. if that is not the issue then I would recomend inserting the windows 7 dvd into the dvd drive of your pc, rebooting to the DVD, and running the automated repair utility. If you installed from a wim OR iso file, you will need to burn the image to a dvd first, as you must runt the repair utility before the OS boots.

If you used a WIM image, and your dvd burning software does not support WIM images, you can Use the IMageX utility in the Windows Automated Installation Kit located at microsoft.com/downloads/details.aspx?FamilyID=c7d4bc6d-15f3-4284-9123-679830d629f2&DisplayLang=en .

If you have not used imageX before I would strongly suggest downloading the third party ImageX gui , GImageX http://www.autoitscript.com/gimagex/ This will let you mount the imaged you ned, and create the iso, so you can burn the dvd, so you can fix your installation of Windows 7.

Before all of this, of course, back up all your data, as the last resort would be a Format, re-install and restore.

All of this assumes, you have a legitimate licensed copy of Windows 7, and not a pirated copy downloaded from a warez sight that preinstalled malware for you.

Hope that Helps!

Also, WinKey+R does not run in admin mode, and running from the search in Windows Seven does indeed work, I use it all the time.

| improve this answer | |
  • Looks like I've run into the issue posted here, sevenforums.com/general-discussion/… But there is no clear solution as to how to fix it. I don't want to do any "hacks" this is a clean install of Win-7 and not an upgrade. – Abhijeet Patel Aug 31 '09 at 6:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.