1

I have a set of MP3 files that Windows Media Player just refuses to add to the library. They are placed in the standard My Music folder. I play them in media player. They just won't be listed in the library.

I've tried dragging them and dropping them on the media player but they still don't appear in the library.

I have an identical laptop where I've also copied the mp3 files and they appear in the library fine.

Any ideas what would cause this?

  • Is the ID3 information of those files fine? Try correcting them with MP3Tag. – Tom Wijsman Aug 23 '11 at 20:07
  • @Tom: thanks I'll take a look into that although it would seem strange that two identical machines would behave differently. – AnthonyWJones Aug 23 '11 at 20:52
  • Oh, in that case you rather might want to look into resetting Windows Media Player in one or another way. – Tom Wijsman Aug 23 '11 at 21:52
2

This article describes how to reset the Windows Media Player Library, you could try it.

  1. Close Microsoft Media Player for at least 30 seconds.
  2. Click Start and then Run.
  3. Type the following into the text box:

    %userprofile%\Local Settings\Application Data\Microsoft\Media Player

  4. Click OK and a folder showing you your library files will appear.

  5. Erase all the files that end with .wmdb.
  6. Open Microsoft Media Player.
  7. Push F3.
  8. Select the locations for your music files.
  9. WMP will reindex your music.
1

The individual files are bugged for me because I added them, then deleted them and tried to add them again.

Make a copy and add that – it will work.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.