4

I have taken a 250G hard drive from my MacBook pro and cloned it sector-by-sector (using Acronis True image; which would be equivalent to running something like dd if=/dev/sda of=/dev/sdb) onto a larger 1TB drive.

The system boots as expected, but the OS still thinks the drive is 250GB. It looks as if it though the physical drive was 250GB and not just the partition, but I could be wrong.

How would I get OSX to recognize the full size of the 1TB drive?

3
  • You probably need to fix the GPT and its backup so that the backup is relocated to the end of the new large drive and the new location is marked correctly in both of them. I am not sure about the exact steps to take and the utility to use though. You may want to look into gdisk (GPT fdisk).
    – Tom Yan
    Jul 4, 2016 at 15:19
  • Is this any use? stackoverflow.com/questions/47704458/…
    – moo
    Feb 5, 2023 at 7:40
  • Is the disk formatted as APFS, HFS+, or something else?
    – moo
    Feb 5, 2023 at 7:41

2 Answers 2

0

I had a similar problem caused by dd: all console tools (e.g. diskutil list) showed correct size of the partition (100 GB in my case), but the Disk Utility and OS X low free space notification thought it was smaller (25 GB in my case).

What I did was to resize the partition to 25 GB using diskutil resizeVolume disk0s2 25G and then resize it back to the max using diskutil resizeVolume disk0s2 limits (substitute your chosen partition for the disk0s2).

It didn't work at first when I tried it on a live partition. But when I retried it from an external disk and added some diskutil verifyDisks and diskutil verifyVolumes between the resize commands, it magically worked.

-1

Might want to give this a try: Resizing HFS+ Partitions, haven't tested this on a MBP but it should work just fine.

1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .