My company has a backup server that has a space in its name ("Foo Bar").

I am trying to add the login credentials for this server to Windows Credential Manager, but I receive a canned error response (I am assuming this is due to the space. No space, no error):

Windows cannot save this information. Make sure the information is correct
and that all required fields are completed. 

Error code: 0x80070057. 
Error message: The parameter is incorrect

I have tried the following:

  • Its network IP address (credential manager doesn't seem to ID an IP and server name as the same?)
  • \\Foo Bar\foobar
  • "\\Foo Bar\foobar" (same 0x80070057 error)
  • \\Foo%20Bar\foobar (does not link to the server)
  • \\FooBar\foobar (doesn't ID)
  • \\Foo-Bar\foobar (doesn't ID)
  • "Foo Bar" (same 0x80070057 error)

Unfortunately, I do not have permission to undertake the simplest solution (properly naming the server!).

Any ideas?

  • Are you sure you don't have permission to give the server a proper name? There may be two ways to do that. #1: Adjust the server's name, on the server. #2: Give the server another name. Adjust name resolution. (a.k.a., try adding a DNS entry, possibly as CNAME, or try modifying a hosts file.) – TOOGAM Jun 22 '17 at 4:41
  • I understand you've tried several different host names. But besides showing us those host names you tried, can you tell us just what you're doing? I'm suspecting using a command line: can you show an entire example of a tried command line? – TOOGAM Jun 22 '17 at 4:42

If you can successfully connect to the share via Net Use I believe you can use the /savecred option to save those credentials into the WCM.

You will probably have to enclose the server/share name in quotes to prevent confusion by the space. IE: Net Use K: "\\Server Name\ShareName"

For the net use command to save the credentials in Credential Manager, use the /savecred switch. When you use the /savecred switch, any credentials that you are prompted for when you use the net use command are saved as a key.

Info here and here.

  • Since the domain name is the server name, I'm having trouble using Net Use to connect; when prompted for the user name, using any of foo bar\user, "foo bar"\user, user@foo bar, "foo bar\user" throws an invalid user name response. – Nick Aug 25 '11 at 17:42
  • 1
    Aha, I was able to bypass the space in the domain by using %domain%\user – Nick Aug 25 '11 at 17:47
  • After successfully connecting via net use with the /savecred switch, I'm not seeing the credentials in WCM :\ – Nick Aug 25 '11 at 17:49
  • @hztetra - Crappy. (Un)Fortunately I've never actually had to do this in practice.. :) Maybe try both "/Savecred" and "/Persistent:Yes"? I doubt it'll help, but should be an easy test. :) – Ƭᴇcʜιᴇ007 Aug 25 '11 at 17:58
  • Also adding Persistent:Yes does not load the credentials into WCM either! I'm feeling defeated, heh. – Nick Aug 25 '11 at 18:01

You can use the ^ to escape certain characters in Windows as well. Not sure if it will work but try \Foo^ Bar\foobar

  • Using a carrot did not work unfortunately :( – Nick Aug 25 '11 at 17:42
  • 1
    "The ampersand (&), pipe (|), and parentheses ( ) are special characters that must be preceded by the escape character (^) or quotation marks when you pass them as arguments." Unfortunately those are the only characters you can escape in a Windows command-prompt. – Ƭᴇcʜιᴇ007 Aug 25 '11 at 17:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.