I accidentally visited gist.gihub.com (note the missing t), and now that URL auto completes each time I start typing gist.…. How can I remove this URL?

I've tried removing it from my history, but that doesn't help:

enter image description here

(note the empty search results)

  • Did you remove all the history or just the last entry ? Aug 26, 2011 at 21:11
  • Sry, don't have Chrome, but have you tried pressing [del] while targeting/hovering that entry?
    – ragnq
    Aug 26, 2011 at 21:12
  • This question has been asked before, but heres the How to Answer[1]. [1]: superuser.com/questions/326531/…
    – Keltari
    Aug 26, 2011 at 21:13
  • 2
    Well, this seems to be an issue. Aug 26, 2011 at 22:30
  • 4
    i have the same problem when i accidentally typed reddit.com/r/gonewild when i meant reddit.com/r/programming. (note the extra g,n,e,w,l,d)
    – Ian Boyd
    Mar 25, 2012 at 13:44

4 Answers 4


Highlight the item (using your keyboard arrows) and use shift+delete

(Note that on the Mac you seem to need to also press fn, so fn+shift+delete)


  • this won't work on URLs that have been bookmarked. For these you must first delete the bookmark, then delete it from the Omnibar history (you can tell it's a bookmark if there's a star next to it as you start typing)
  • you must select the entries in the Omnibar history using the arrow keys to select
  • 2
    This works. Although it should be mentioned that rather "for example your keyboard", you must use your keyboard. You cannot leave an item highlighted with your mouse, and leaving the mouse-button down will prevent Shift+Delete from deleting.
    – Ian Boyd
    Mar 25, 2012 at 13:48
  • 3
    Didn't work for me on 10.7.4, chrome 19.0.1084.52 Jun 6, 2012 at 13:25
  • 3
    Doesn't work for me. Chrome 27.0.1453.110. Macbook Pro, Snow Leopard. Jun 12, 2013 at 0:19
  • 6
    this answer is no longer valid, 38.0.2125.122. I tried combinations of command, shift, fn, and delete on my mac book pro and the entry doesn't go away. We recently changed domain name and I have a history full of now broken urls, so very annoying. Nov 17, 2014 at 17:48
  • 5
    This will NOT WORK if the URL is in your bookmarks. Instead, delete from your bookmarks. Feb 22, 2015 at 19:06

Low level answer, if you want to know the whole list:

This is stored in an sqlite3 database in Google Chrome's userprofile folder, on Linux it's located in

~/.config/google-chrome/Default/Top Sites

You can use SQLite3 to have a look at it:

me@local~/.config/google-chrome/Default$ cp Top\ Sites ts.sqlite
me@local~/.config/google-chrome/Default$ sqlite3 ts.sqlite ...
sqlite> .schema
sqlite> select url_rank,url from thumbnails order by url_rank;

To answer your question:
You can delete or edit an entry using regular SQL commands, but be sure that Chrome is not running, i.e. the file is not opened (by Chrome). Also note that I did all actions on a copy because of that (was only looking).

  • this would be a really great answer if you could fill in the missing parts currently hidden by "...". What is the delete statement? and ... why don't show tables or .tables work?
    – Abe
    Jan 25, 2013 at 19:50
  • 2
    The "..." just just hide the standard login prompt from sqlite3, my Top Sites ranked 1-20 which I didn't want to disclose and parts of the schema that are not necessary for the answer. SQLite uses standard SQL statements, so just write the statement yourself if you're familiar with it. I didn't include that delete statement on purpose. Type .help to get help on SQLite usage or see the man page here: linux.die.net/man/1/sqlite3
    – ce4
    Jan 25, 2013 at 20:14
  • Sorry, I had two errors; first was misspelling the file extension .sqlite (so .schema returned nothing; so I thought that your create statement was a command to be issued ...) and then assuming that familiar mysql commands like show tables; must be standard. But now that I am over those hurdles I should be okay.
    – Abe
    Jan 25, 2013 at 23:06
  • so, after doing sqlite3 Top\ Sites; delete from thumbnnails where url = "http://www.example.com";, I still see the unwanted site. Also, for the record, the README says "Google Chrome settings and storage represent user-selected preferences and information and MUST not be extracted, overwritten or modified except through Google Chrome defined APIs.". In any case, thanks for getting me a chance to check out sqlite.
    – Abe
    Jan 25, 2013 at 23:18
  • 1
    :-) Yeah, "show tables" is not SQL really, it's a little different in sqlite, I also have to use .help each time I use it to get it right...
    – ce4
    Jan 25, 2013 at 23:19

I have found several places that mention Fn+Shift+Del for a mac and Shift+Delete for windows.
I do use windows, and from my experience I often needed to use Fn+Shift+Delete.

  • 1
    Wrong answer. Not valid. This method is obsolete.
    – superuser
    Feb 9, 2015 at 6:09
  • Thank you, works perfect on Mac! Other suggested Shift+Del, but that didn't work for me. NOTE!! You MUST use the arrows to scroll down to the entry you want to delete and use Fn+Shift+Del (on Mac)
    – Ali Alwash
    Jun 9, 2016 at 8:06
  • Does not work on mac, El Capitan Oct 20, 2016 at 10:34

I found a solution.

Highlight the item in the address bar drop-down box by pressing the left mouse button over it, but don't release the mouse button, continue holding it. Then press shift with your other hand, hold it, then take the hand with your mouse up and while keeping the button pressed , press the delete button with your little finger on the right hand.

  • 2
    Tried, and failed. It deletes the autocompleted portion of the url, but leaves it in the auto-complete history.
    – Ian Boyd
    Mar 25, 2012 at 13:45
  • Doesn't work for me. Jun 19, 2013 at 21:06

Not the answer you're looking for? Browse other questions tagged or ask your own question.