I'm using Windows 7 and a Razer headset.

I was using Skype, talking to a friend with just the pink jack plugged in so that I can hear his voice through speakers and he can hear me perfectly fine.

I exited Skype, used Google and YouTube for a while, then turned Skype back on to talk to my friend when the following happened:

I was playing Team Fortress 2 at this point when my friend said "Hi" - I heard him clearly through the speakers (along with Team Fortress 2) and I reply back. However he messaged me to say that he couldn't hear me and that he could only hear my game.

I hit the "Listen to this device" option under sound to see what he was talking about and clearly enough, my mic is only playing sound off my computer, like music, videos, games, anything. Anything that's entering the mic (like my voice or even blowing on it) has no effect at all.

Previously I noticed there was a sound enhancer option or something under the sound menu in Control Panel, which allowed you to add more db or some thing or subtract more db. That entire option is gone now.

Any ideas how to fix this?


It sounds like you have some sort of Audio Loop Back adapter.

Right click on the Audio Icon, and click Recording Devices. From here, make sure that your Microphone is selected as default.

enter image description here

In addition, go in to Skype and go to Tools > Options then Audio Settings and make sure the Microphone is set correctly.

enter image description here

Finally, if this doesn't help, take a look at TF2's Audio options and see if it is doing anything funky - I doubt this, but, it is worth a try.

  • The tf2 is not the problem. I know this because even with tf2 off or uninstalled it's still doing this. The mic is on default, and the mic is correct in skype. Both of your windows look exactly the same. The only diffrence is my mic can't heard in skype like yours is. Any other suggestions? – Robolisk Aug 29 '11 at 23:47
  • @Robsta, the only other thing I can suggest is to look in the specific control panel of your audio card/chip and see if there are any options such as loopback/echo or whatever they call it.... Other than this, if it happened all of a sudden with no changes on your machine, it is possible (but unlikely) you have a faulty unit :/ – William Hilsum Aug 29 '11 at 23:53
  • I just used a usb mic and it worked fine. But front and back ports for mic don't work with this headset, im trying to get a hold of another headset thats just like mine (non usb) and see if it is either my headset or my computer for certain. And i'm sorry, I don't understand what you said about the audio card/chip control panel thing. Thank you. – Robolisk Aug 30 '11 at 4:23
  • @Robsta - Many drivers for computer audio come with their own control panel with options that you can't configure anywhere else, it is worth looking to see if you have one. – William Hilsum Aug 30 '11 at 11:13
  • Turned out my mic was dead. In a strange way, but this is helpful and very well informed. It helped me with a lot of trouble shooting. – Robolisk Sep 9 '11 at 13:21

I had the same problem, my mic would not work either. I guess it was just the headset, or in this case the microphone of it. I bought a new one and now I don't have any problems any more.


i had this problem since so long ago ! But finally i got this solved. Its a rather simple thing...go into the realtek audio interface and check "Echo cancellation" ..This will do the trick. Im sure. if its not realtek, go throughout your audio settings, check any "echo cancellation" you can see. :)

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.