I just got a non-working Vista box from a friend, so I re-imaged the HD with a new version of Vista and the first time I booted it a 'Found New Hardware' dialog box came up with a prompt to install drivers for the GeForce 7300LE graphics card.

I installed the drivers, and of course the system needed a refresh, so it automatically rebooted and when it started back up, I got a BSoD. (I don't remember what the error code was.)

I tried booting again with 'Last Known Good Configuration' and it booted successfully, but the only graphics card that shows up anywhere is a 'Generic VGA driver'.

Add Or Remove Programs shows the NVIDIA drivers as installed, but the card doesn't show up anywhere in the system.

Any idea what is wrong here and what I can do to get my card to work?

  • I uninstalled and reinstalled the NVIDIA drivers, and the system crashed (again).
    Maybe part of the problem is bad drivers?

  • I downloaded and installed the latest drivers and I got 2 BSoDs (errors 116 and 50)

  • The card is (somewhat) working, because there is no onboard graphics. It is currently using a driver from Windows which is just a standard VGA driver (no 3D support of any kind). The problem comes up when I try to use any NVIDIA drivers

  • I'm going to try baking it; let's see how that works.

  • On boot, there are about 12 groups of four blue vertical lines on the screen during the BIOS boot, the Windows splash screen, and when using a full-screen DOS program. (they go away when Windows boots all the way)

  • I talked with some local computer service reps about this, and (@techie007 you seem to be right) they think that it is the card, not the drivers, because of the blue lines. Time to look for a new card.

  • Did you click scan for hardware changes? – soandos Aug 31 '11 at 0:16
  • @soandos yep and nothing changes – Nate Koppenhaver Aug 31 '11 at 0:55
  • When installing the driver, did it ask/warn you it was about to reboot, or did it just 'spontaneously', and without warning, reboot? – Ƭᴇcʜιᴇ007 Aug 31 '11 at 19:22
  • @techie007 the installation finished, and then it was just the standard 'you have made a system hardware change. a reboot is required before you can use your new hardware' type of message – Nate Koppenhaver Aug 31 '11 at 19:26
  • 1
    So it didn't 'automatically' reboot. Gotcha. (PS: It sounds like a busted card. :) – Ƭᴇcʜιᴇ007 Aug 31 '11 at 19:31

That's videocard gone wild. I have the same situation, blue/red/white stripes with hallucinogenic behaviour. In my case it's Geforce 7400 Go that decided to "go".


Do you have an onboard graphics card? If so try the following:

Remove all the PCI cards from the machine and boot it up. Shut the machine down and add 1 PCI card in at a time, booting after each one. Sometimes this can correct issues with PCI cards problems.

  • should I uninstall the NVIDIA drivers first? – Nate Koppenhaver Aug 31 '11 at 0:55
  • it couldnt hurt. – Keltari Aug 31 '11 at 1:01
  • turns out that that's the only PCI card in the system, and no onboard graphics – Nate Koppenhaver Aug 31 '11 at 1:45

You should check the bios if plug and play is enabled, if that's an option at all, and reboot into safe mode. From there follow directions to completely remove old drivers. Then get the drivers from nvidia's site (not windows update) and install them. I understand you've done this once, but I think that incomplete removal of drivers or vista bundling in drivers that don't properly support the 7300LE though they think they do (the firmware can get changed) might be your issue.

  • Nope. Still gives a BSoD (116) on reboot after installing the NVIDIA drivers – Nate Koppenhaver Aug 31 '11 at 21:43
  • I didn't see EDIT #6 when I answered so, clearly you've found it to be your hardware. Aside, a long time ago Voodoo3, and some ATi cards used to have 2 different firmwares, one for PCs one for Macs (OpenFirmware in Forth), so you'd have to reflash the firmware when switching platforms. But the 7300LE is too new for that problem. – dlamblin Sep 12 '11 at 18:45

Well, I tried baking it, and nope, there is no magic bullet to revive old graphics cards. (when I plugged it in, I got crazy patterns of flashing multicolored lines across the screen. It looked like somebody having a nightmare while high on a hallucinogen :) Thank you all for your help, but I'm going to be making a trip to the local computer parts store today :)


Some of the older Nvidia-based graphics cards are no longer supported by the newest drivers.

You might try the following site, which recognizes this problem and supplies the latest driver which does support the card, once it get sufficient information about the card, the operating system and so on:


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.