My Windows7 firewall is blocking access to a SQL Server database on a remote server via SQL Server Management Studio. I'm VPN'd to the network the server is on, I can ping it, and I can transfer files to/from it.

"Cannot connect" error: "A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections...."

I can connect to another remote SQLS DB, on a public server (i.e., no VPN in my way), and to the DB on my localhost server.

I can connect like the good old days (early June and before) if I

  1. turn off the win7 firewall in the "Private" profile; or more specifically,
  2. Allow (all) inbound connections on the Private profile firewall

(And once I've connected, turning the firewall back on w/defaults doesn't prevent me from talking to the DB in SSMS via the connection made.)

Inbound and Outbound Rules are set default, to block the former, and allow the latter unless excluded. I see nothing in either list for ports 1433 and 1434, or with a name related to SSMS. Tried adding inbound rules to specifically allow all of TCP 1433-4 and UDP 1433-4 (on my side, "any" on the remote), and no joy.

Logging dropped packets, I see that incoming traffic to UDP port 1434 is being dropped:

2011-08-29 11:12:37 DROP UDP 1434 59228 152 - - - - - - - RECEIVE


This problem is very strange, very specific. Hope someone can see what I'm missing here.

migrated from stackoverflow.com Aug 31 '11 at 3:54

This question came from our site for professional and enthusiast programmers.

  • Sounds like the issue is on the remote server, not on your win 7 box. Is that SQL server configured fro remote connections, as the error states? – Jimbo Aug 29 '11 at 18:00
  • Remote server was ruled out early on, with a WinXP box in the house. It connects "as usual" (and indeed as this one did until recently). Turning the Win7 firewall off gets me in. For the moment, I've worked around with an Incoming rule to allow SSMS on the Private profile. Maybe that's "the" fix, but it's a mystery why action was needed. – fortboise Aug 29 '11 at 18:45
  • 2
    Closed as off topic, huh. So programming infrastructure isn't about programming? Funny dat, given how much of my programming time is dealing with infrastructure problems. – fortboise Aug 31 '11 at 2:18
  • possible duplicate of firewall blocks connection even though allowed – Nacht Nov 9 '14 at 22:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.