I set up Windows 7 Pro to backup my files to a network path (woohoo!) and chose to backup "data for newly created users, libraries", and my user folder (no system image).

All went fine (although the first backup took ~12 hours for some ridiculous reason), but at the end it gave me a message that "Your backup completed, but some files were skipped. Click to see which files."

I checked and the "files" skipped were my 3 network-mapped drives, which is perfectly fine and reasonable behavior (I certainly don't need it to back up my network-mapped drives as part of my local PC backup), but in the Backup and Restore center it warns me that my Last backup was "Never" and the Action Center now has a permanent "Check your backup results" issue. Is there any way to set up the backup to exclude the network-mapped drives or tell it that I really don't mind that it skipped drives I never asked it to back up?


I've had the same error message with error code 0x80070002/3.

The question is: why is MS Backup trying to backup non-existant data and then reporting that it cannot reach it?

The reason is related to the way user Libraries (new feature in Windows 7) are managed: you can add any existing folder to a library, so that all files in different locations are seen as an homogeneous group (like all your videos), but if a folder previously included is deleted, renamed, or moved (thus the path doesn't exist anymore), the library continues to behave as if it still existed.

When the Backup application is commanded to save a library -- by selecting one or more user libraries to include in the backup -- it translates the name of the libraries into a list of individual folders which it tries to backup, including the ones that are now missing, and reports the error.

The fix is to remove the deleted or moved folders from the library content, after making sure that the library is visible in the navigation pane (this is ensured using the check box in the properties drop down, that you find when you right click on the particular library icon).


Turns out it wasn't the network-mapped drives, but additional Library locations. When WHS installed, it added its shares to the appropriate libraries. Removing those from the libraries solved the problem. If you wanted to keep any network locations in the libraries, it looks like you'd have to put up with this error message.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.