15

I'm trying to get a RTMP stream to play on VLC and the URL is in this format: rtmp://76.10.10.240/liverepeater/mp4:name.mp4

I'm able to record the stream with CooJah but I only want to watch it via VLC. Any ideas?

4
  • Did you try asking on #videolan on freenode? – Akash Sep 7 '11 at 11:43
  • @Akash No, I didn't – kbtz Sep 8 '11 at 19:03
  • Do try it out.. you are more likely to get help on the IRC/forums/mailing list – Akash Sep 8 '11 at 19:09
  • The KMplayer plays rtmp streams ;) – user103785 Nov 1 '11 at 23:58
14

You can play RTMP in VLC with the help of RTMPDump .

rtmpdump -v -r "rtmp://ip-address/app-name/streamname" -o - | "vlc" -
2
  • I'll check it out... – kbtz Feb 24 '14 at 14:03
  • Check and let me know... – Unnikrishnan Feb 25 '14 at 11:52
1

Sorry, but VLC doesn't support rtmp streaming just yet. If you really want to stream RTMP, you could use flowplayer since they support it, but it's not as easy as using VLC.

1

Yes! Now you can do it in VLC. Because the new versions of VLC from v1.1 onwards support rtmp stream playing.

  1. Just Click on Media.
  2. Click on open network stream / or press Ctrl/command + N
  3. Write rtmp URL.
  4. Enjoy!
4
  • 3
    No, its not playing, it throws stream not found error! – Gopi Jun 25 '13 at 12:13
  • no it won't work – M. A. Nov 12 '16 at 16:20
  • it only works with some rtmp streams – user3791372 Apr 21 '17 at 17:42
  • why VLC asks me to open accessibility on Mac? It feels so dangerous. – Shark Deng Dec 12 '20 at 2:14
1

On Mac/OSX, I was able to get this to work with a modification of Unnikrishnan's answer. The important part being the path to the VLC executable (which may vary by system)

Recorded Stream:

rtmpdump -r rtmp://path/to/stream | /Applications/VLC.app/Contents/MacOS/VLC -

Live stream

rtmpdump -r rtmp://path/to/stream --live | /Applications/VLC.app/Contents/MacOS/VLC -

You should then see a VLC window open, with fs://0 listed in the playlist area. Double-click that entry to view the actual stream.

2
  • I've tried rtmpdump -r rtmp://path/to/stream --live -o | "c:\Program Files (x86)\VideoLAN\VLC\vlc.exe" on windows 8.1 but it seems it does not work, any idea ? – M. A. Nov 12 '16 at 16:27
  • 1
    @AbdelhafidMadoui My approach is using the OSX terminal, so I'm not sure it would work properly in Windows. In Windows 10, there is a new ability to install a "native" Bash prompt, which also supports calling Windows executables – providencemac Nov 21 '16 at 15:42
1

VLC version 2.2.4 can play, Hit Cmd+N (on MAC) and enter the url in this format

rtmp://Server URL/live/Stream Name

e.g rtmp://10.154.136.221/live/RTMP1

1
  • This information solved my <playpath> problem. I converted my rtmp link rtmp://streaming.perculus.com/vods3<playpath>flv:blabla.flv to rtmp://streaming.perculus.com/vods3/live/flv:blabla.flv Now it works perfectly. – sevenkul Oct 19 '17 at 9:48
0

You need to use mplayer or at least rtmpdump from mplayer as vlc has no rtmp support currently.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.