2

I use Windows 7 x64. I thought I disabled Autorun - that is nothing happens when DVD/CD is inserted. However, by accident I found out that if in Windows Explorer I go to "My Computer" and then double-click on DVD icon in the right pan Autorun still works. Is there a way to disable this as well?

1

What you are running into isn't AutoRun, or AutoPlay. It's the 'default action' for double clicking on a DVD, which is "Play". If you right-click the drive (with a DVD in it), you'll see "Play" is highlighted.

If you would prefer it to "Open" the DVD as a folder instead of playing the movie when you double-click the drive, then you could try editing the registry and change the action for the "DVD" class:

  • Open regedit.exe.
  • Navigate to HKEY_CLASSES_ROOT\DVD\shell
  • Change the "Default" value data from "Play" to "Open" (without quotes).

I believe the change should take effect immediately, but I'm not 100% sure, as I don't have a DVD disc around to test with right now. :)

  • 1
    Yep, that did it. Took effect immediately, no reboot needed. – Joe Schmoe Sep 5 '11 at 21:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.