Is there any way to create and format a partition using a Bash script?

I think it can be done with fdisk but I don't know how to feed commands from the Bash script into the fdisk shell and then exit the fdisk shell.

I'd like to create a partition then format it to NTFS from within Bash.


12 Answers 12


Similar to the previous suggestions, piping commands to fidsk, I've found this approach useful to leave details for subsequent maintainers. The sed bits strip off all the comments before fdisk gets the input.

# to create the partitions programatically (rather than manually)
# we're going to simulate the manual input to fdisk
# The sed script strips off all the comments so that we can 
# document what we're doing in-line with the actual commands
# Note that a blank line (commented as "defualt" will send a empty
# line terminated with a newline to take the fdisk default.
sed -e 's/\s*\([\+0-9a-zA-Z]*\).*/\1/' << EOF | fdisk ${TGTDEV}
  o # clear the in memory partition table
  n # new partition
  p # primary partition
  1 # partition number 1
    # default - start at beginning of disk 
  +100M # 100 MB boot parttion
  n # new partition
  p # primary partition
  2 # partion number 2
    # default, start immediately after preceding partition
    # default, extend partition to end of disk
  a # make a partition bootable
  1 # bootable partition is partition 1 -- /dev/sda1
  p # print the in-memory partition table
  w # write the partition table
  q # and we're done
  • 6
    I completely agree. Document your work for others to read. Nov 26, 2015 at 13:55
  • 2
    Note you have to have a leading tab on each line.
    – Stu
    Dec 4, 2015 at 19:06
  • 5
    Would you mind placing a big warning that a tab is required on each command character line as @Stu mentioned? I had to debug for a while just because copy-and-paste ignores tabs and replaces them with spaces, thus regex does not match with command lines.
    – ceremcem
    Mar 27, 2016 at 1:30
  • 16
    Instead of a warning about tabs, I've modified the sed to discard leading whitespace (not just tabs) and not expect a tab after the fdisk commands. This should cut and paste better. @ceremcem - good feedback and sorry to caused you any debug time. Apr 10, 2016 at 15:15
  • 3
    sfdisk is more automation friendly than fdisk
    – spuder
    Feb 2, 2017 at 17:32


sfdisk is a Scripted version of fdisk.

It is part of util-linux, just like fdisk, so availability should be the same.

A partition table with a single partition that takes the whole disk can be created with:

echo 'type=83' | sudo sfdisk /dev/sdX

and more complex partition tables are explained below.

To generate an example script, get the setup of one of your disks:

sudo sfdisk -d /dev/sda > sda.sfdisk

Sample output on my Lenovo T430 Windows 7 / Ubuntu dual boot:

label: dos
label-id: 0x7ddcbf7d
device: /dev/sda
unit: sectors

/dev/sda1 : start=        2048, size=     3072000, type=7, bootable
/dev/sda2 : start=     3074048, size=   195430105, type=7
/dev/sda3 : start=   948099072, size=    28672000, type=7
/dev/sda4 : start=   198504446, size=   749594626, type=5
/dev/sda5 : start=   198504448, size=   618891264, type=83
/dev/sda6 : start=   940277760, size=     7821312, type=82
/dev/sda7 : start=   817397760, size=    61437952, type=83
/dev/sda8 : start=   878837760, size=    61437500, type=83

Once you have the script saved to a file, you can apply it to sdX with:

sudo sfdisk /dev/sdX < sda.sfdisk

For sfdisk input, you can just omit the device names, and use lines of type:

start=        2048, size=     3072000, type=7, bootable

They are just ignored if present, and the device name is taken from the command line argument.

Some explanations:

  • header lines: all optional:
    • label: type of partition table. dos (MBR) is the old and widely supported one, gpt the new shiny thing.
    • unit: only sector is supported. 1 sector usually equals 512 bytes. Find with cat /sys/block/sda/queue/hw_sector_size. See also: Finding the sector size of a partition
    • device: informative only I think
  • partition lines:
    • start: offset inside the disk at which the partition starts.

      start has very good defaults, and can often be omitted:

      • on the first line, start is 2048, i.e. 1Mb (2048 + 512), which is a sane default for disk compatibility
      • further start entries default to the first unallocated position
    • size: man sfdisk says: The default value of size indicates "as much as possible". So to fill the disk with a single partition use: /dev/sda : start=2048, type=83

    • type: magic byte stored on the boot sector for each partition entry. Possible values here: https://en.wikipedia.org/wiki/Partition_type On this example we observe:

      • 7 (sda1, 2 and 3): filesystems that Windows supports. Preinstalled Windows stuff and Lenovo recovery partitions. sudo blkid labels help identify them.
      • 5 (sda4): extended primary partition, which will contain other logical partitions (because we can only have 4 primary partitions with MBR)
      • 83(sda5, 7, and 8): partitions which Linux supports. For me one home, and two roots with different Ubuntu versions
      • 82 (sd6): swap

fdisk can also read sfdisk scripts with the I command, which "sources" them during an interactive fdisk session, allowing you further customization before writing the partition.

Tested on Ubuntu 16.04, sfdisk 2.27.1.

Format and populate the partitions an image file without sudo

This answer is a good way to learn to use sfdisk without blowing up your hard disks.

  • 4
    OMG this is amazing. I've used fdisk before but if you accidentally land exactly where there is already a partition it will want verification from the user that it doesn't usually require, which sucks. sfdisk is wonderful, thank you!
    – TaborKelly
    Aug 15, 2018 at 22:59
  • Note that GPT uses GUIDs for partition types instead of hex codes: en.wikipedia.org/wiki/GUID_Partition_Table#Partition_type_GUIDs
    – DustWolf
    Jul 29, 2021 at 15:32
  • I got an error "Failed to add #1 partition: Invalid argument" it's a brand RIAD5 4.4TB disk. I did echo 'type=83' | sfdisk /dev/sdb What could be the reason? Aug 10, 2021 at 2:42
  • @KenjiNoguchi sorry, not sure, let me know if you manage to fix it. What's your OS name and version BTW? Aug 10, 2021 at 8:33
  • very easy to get disaster. I would prefer some declarative language to do this. All fdisk never really mk the file system, which is another inconvenience.
    – Wang
    Dec 26, 2022 at 23:45

fdisk reads from stdin so you just need to feed it the appropriate commands. For example, the following clears the partition table, if there is one, and makes a new one that has a single partition that is the; entire disk:

echo o # Create a new empty DOS partition table
echo n # Add a new partition
echo p # Primary partition
echo 1 # Partition number
echo   # First sector (Accept default: 1)
echo   # Last sector (Accept default: varies)
echo w # Write changes
) | sudo fdisk

I recommend you do the task you want, recording what you type so you can reproduce it.

  • 9
    While a bit more verbose with the echo commands than the accepted answer, this seems much less magical and obfuscated. Nov 12, 2016 at 13:05
  • 1
    I personally would suggest the use of printf instead of echo just to be in the habit of using something that behaves consistently across systems. Jul 5, 2017 at 19:22
  • @vastlysuperiorman I don't think that printf would work as in-place replacement for echo as it doesn't insert the line break
    – Andrey
    Dec 12, 2019 at 17:41
  • 1
    @Andrey you are correct. The equivalent of echo o here would be printf "o\n" which looks less clean. I personally prefer printf because it feels more intentional, but echo is a totally valid solution. Dec 12, 2019 at 18:09
  • 1
    I suppose you could use {} but you would have to terminate each command with ; in that case.
    – e40
    Aug 4, 2021 at 16:09

You can do it with just a couple of commands, use intros \n instead of multiple echos.

echo -e "o\nn\np\n1\n\n\nw" | fdisk /dev/sda
  • This is more terse than the others, but unfortunately seems to only work with bash.
    – bk138
    Feb 9, 2015 at 18:34
  • It's working with ash/busybox too. Feb 10, 2015 at 8:59
  • 2
    Is another \n needed after the w?
    – Qian Chen
    Jul 17, 2015 at 13:48
  • 8
    This works, but is horrible :-) Sep 9, 2015 at 13:23
  • 2
    @ElgsQianChen: no, because echo automatically terminates the line with a newline (unless -n option is used)
    – Udo G
    Nov 9, 2015 at 8:14

Create a new disklabel type gpt:

sudo /sbin/parted /dev/xvdf mklabel gpt --script

Partition the disk:

sudo /sbin/parted /dev/xvdf mkpart primary 0% 100% --script

  • 2
    Thank you, this is the only clean solution for me cause it dosn't include piping some kind of "space opera.docx" to fdisk.
    – Benibr
    Mar 7, 2018 at 14:52
  • you have to call separated commands to mk file system, which is not very nice
    – Wang
    Dec 26, 2022 at 23:42

You can script fdisk.

(echo n; echo p; echo 1; echo 1; echo 200; echo w) | fdisk /dev/sdc

That creates a 200 MB partition on /dev/sdc


Piping commands to fdisk works well as explained by other people, but this way a bit more elegant and readable:

fdisk /dev/sdc <<EOF


Piping from a (temporary) file also works:

fdisk /dev/sdc < /tmp/fdisk.cmds
  • This one gets my vote. It's clean and isn't polluted with a running commentary.
    – David Betz
    Aug 8, 2016 at 15:25
printf 'o\nn\np\n1\n\n\nw' | fdisk /dev/sda
  • 3
    A common mistake new users make is to answer without details of how to actually resolves the issue. Answers should be detailed and include references, as needed. Please take a few minutes to edit your answer to include details of why your answer is valid. If you need some help, read How do I write a good answer?. Also, please realize you have posted an answer to a very old questions which has an accepted answer. Although there is noting wrong with doing so, you may not get a response from the OP.
    – CharlieRB
    Mar 23, 2016 at 19:49
  • 1
    Is this different from: superuser.com/a/739586/128124 ? Oct 8, 2016 at 14:22

The script uses fdisk to create partitons based on other people answers.

Change the following in the script:



Example usage is given after the script.

if [ $# -eq 0 ]
  echo "input the device"




for i in $(seq $NUM_PARTITIONS)
  if [ $i -lt $EXTENDED_PART_NUM ]
  if [ $i -eq $EXTENDED_PART_NUM ]
  if [ $i -gt $EXTENDED_PART_NUM ]

sed -e 's/\s*\([\+0-9a-zA-Z]*\).*/\1/' << EOF | fdisk ${TGTDEV}

run with:

sudo sh mk_partition.sh /dev/sdxxx


Not that anyone's asking but I thought I will just share it here since I bumped into it. I tried applying the following sfdisk command on Centos 7:

echo 'type=83' | sudo sfdisk /dev/xvdb

But received the following response:

Checking that no-one is using this disk right now ...

Disk /dev/xvdb: 1958 cylinders, 255 heads, 63 sectors/track
sfdisk:  /dev/xvdb: unrecognized partition table type

Old situation:
sfdisk: No partitions found

sfdisk: trailing junk after number

sfdisk: bad input

Finally this is what worked for me:

sfdisk -f -uS -D /dev/xvdb << EOF

Below is a working script. In the working dir, the overlay dir contains the file image and the mnt dir is used to temporarily mount the image.



rm -f $filebase.zip

dd if=/dev/zero of=$filebase.img bs=64M count=1

echo n # Add a new partition
echo p # Primary partition
echo 1 # Partition number
echo   # First sector (Accept default: 1)
echo   # Last sector (Accept default: varies)
echo t # Partition type
echo 6 # FAT16
echo a # bootable
echo w # Write changes
) | sudo fdisk $filebase.img

sudo losetup -P /dev/loop777 $filebase.img
sudo mkfs.fat -F 16 -n Anx4Init /dev/loop777p1
sudo mount -t vfat /dev/loop777p1 mnt
sudo cp -R overlay/* mnt

sudo umount mnt
sudo losetup -d /dev/loop777

zip $filebase.zip $filebase.img

rm -f $filebase.img
hdd="/dev/hda /dev/hdb /dev/hdc"
for i in $hdd;do
echo "n

"|fdisk $i;mkfs.ext3 "$i1";done 

You can use this script. Just make sure you define your own partitions where hdd is defined. There are 2 blank spaces between 1 and w; they need to be there for taking default values.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .