How do I remove Skype from the Windows 7 taskbar, at least when it's minimized? Skype disappears from the taskbar in both Windows XP and Windows Vista, not sure if by default now, but I cannot make it do so in Windows 7. I have it showing in my notification area, and this is good enough for an "always on" program like Skype.

I have a feeling there is no standard solution to this problem until Skype updates with a fix.

migrated from stackoverflow.com Sep 6 '11 at 15:06

This question came from our site for professional and enthusiast programmers.

  • How do I get negative rep for asking this? It takes me below 10 and I can no longer edit another question of mine that used above 10 privileges. – Xonatron Sep 6 '11 at 14:43
  • It doesn't belong here. When it has been migrated, you can do a recalc and should probably get your rep back. – Kate Gregory Sep 6 '11 at 15:03

See this article from Skype FAQ for the solution(s): How do I remove Skype from the Taskbar?

When you are signed in to Skype, the Skype logo is displayed in the Windows taskbar. You can also see your Skype status icon displayed in the system tray at the bottom of your screen.

If you close the Skype window, the Skype logo and status icon still appear in both the Windows taskbar and the system tray.

To remove Skype from both the Windows taskbar and the system tray, right click the status icon in the system tray and select Quit. This completely closes the application and signs you out, which means you will no longer receive instant messages or calls through Skype.

You can change your settings so that Skype is removed from the Windows taskbar when you close the application window by clicking X. This doesn’t sign you out, so you can still receive calls and instant messages while Skype runs in the background. You will still receive notifications for any IMs you receive in the system tray.

To do this:

  1. Sign in to Skype.
  2. Select Tools > Options....
  3. Select Advanced > Advanced Settings.
  4. Uncheck the box next to Keep Skype in the taskbar while I’m signed in.
  5. Click Save.

Now every time you close the application window, Skype should no longer display in the Windows taskbar. If it does, then you may have to change the program properties. To do this:

  1. Click the Start menu.
  2. On Windows 7/Vista: Select Computer. On Windows XP: Select My Computer.
  3. Open Local Disk (C:)
  4. On Windows 7/Vista: Select Program Files(x86). On Windows XP: Select Program Files
  5. Locate and open the folder named Skype.
  6. Open Phone.
  7. Right-click Skype.exe and select Properties.
  8. In the Compatibility tab, uncheck the box next to Run this program in compatibility mode for:
  • Wow, that was easy. How did I miss it? Maybe I deserved the -1 rep someone gave me. :S Thank you. Hopefully this helps someone else. – Xonatron Sep 6 '11 at 16:06
  • 1
    The only dumb question is the one that you don't ask. Lack of knowledge isn't so bad when you know you are lacking. It should be what you don't know that you don't know that should keep you up. – surfasb Sep 6 '11 at 16:25

there's a program called TrayIt and I'm sure a dozen more. It should do the job for any application that doesn't minimize to the sys tray.

  • Thanks for this. If there's no better "official" way to solve this, I will give it a try. – Xonatron Sep 6 '11 at 14:54
  • There is an official solution, for anyone reading. See top answer. – Xonatron Oct 5 '11 at 14:04

The Windows 7 styleguide doesn't allow programs anymore to remove themselves from the taskbar. Even more, Microsoft wants to discourage users/developers to put their programs in the notification area. See http://msdn.microsoft.com/en-us/library/aa511258.aspx for more information

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.