0

Specs: Windows 7 x64 IE 9 (using x86 version)

For some reason, whenever I click on a .url file, it will not take me to the destination. It doesn't even open a blank tab. It doesn't do anything. All of the favorites now have a generic globe icon. (Not sure what this implies, if anything at all.)

In an attempt to resolve this issue I have done the following:

  • Ran a virus scan (clean)
  • Ran a malware scan (clean)
  • Check default program for .url (Set to IE)
  • Checked the favorites registry entry (All set)
  • Reset my IE settings (Did not delete personal info)
  • Created new favorite files (New ones were just as broken)
  • "Uninstalled" and reinstalled IE
  • Ran Windows Updates (None for IE, but did update some stuff anyways)
0

Try this one on for size. I realise it's aimed at XP but it's worth a try.

Recently I've had several Windows XP computers that all of the sudden have their Internet Explorer Favorites or their Internet Shortcuts stop working. You see all of the Favorites however when you click on them IE does nothing.

Try this out if this is what you are seeing:

  • Open Registry Editor and navigate to:
  • HKEY_CLASSES_ROOT\InternetShor­tcut
  • Backup this key and save as REG file.
  • Now delete 'InternetShortcut' key.
  • Open Internet Explorer, Tools, Internet Options, Programs
  • Choose "Reset Web Settings"
  • The URL association should be rebuilt now.

Source: http://thetazblog.taznetworks.com/2005/04/internet-explorer-favorites-or.html

  • Thanks for the article, but sadly it did not work for me. What a great find though! – Easternwind Sep 9 '11 at 19:48
0

I saw this was unanswered from a past life. I ended up rebuilding my machine. Clean install of OS. A bit of a drastic solution, but that is what worked.

0

As suggested by the Microsoft community, try resetting Internet Explorer settings:

  1. Close all Internet Explorer windows. Select the Tools button [or Control Panel > Network and Internet], and then select Internet options.
  2. Select the Advanced tab, and then select Reset.
  3. In the Reset Internet Explorer Settings dialog box, select Reset.
  4. When Internet Explorer finishes applying default settings, select Close, and then select OK. Restart your PC to apply changes.

These steps resolved the same issue for me.

  • Thanks for the answer, but can you describe how to reset those settings in your answer here? :) – bertieb Jun 25 '18 at 15:06
  • @bertieb Sure, just did. – Lucas Jun 25 '18 at 15:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.