I'm trying to make my OpenSUSE desktop box work with a DLink wireless N Nano adapter. Additionally I'd like to make it the access point for my laptop.

The problem is - when I run hostapd (with r8712u kernel module loaded via modprobe) it fails with the following message:

nl80211 not found.
nl80211 driver initialization failed.

OKay, when I tried (my mistake) to use rtl8192se PCI driver it could find nl80211 (needed compat-wireless for that though) but failed with a message about cannot create mon.wlan0 interface blah-blah

I'm pretty sure that I missed something because that device was reported to work with OpenSUSE 11.4 out of box.

Maybe that r8712u driver kernel module does not properly load all the needed dependency modules and I could modprobe them manually?

EDIT: I did modprobe mac80211 and now hostapd fails with following message:

Failed to create interface mon.wlan0.
nl80211 driver initialization failed.

It seems that my wifi dongle cannot work in monitor mode as needed by hostapd. Anyway the r8712u driver was just freezing my whole system whenever it connected to an ad-hoc network. Maybe more luck with new kernel or ndiswrapper but I'm off for now because I'm tired :]

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.