I have a broken DVD drive and no others available right now to burn a DVD iso to so I'd like to use a empty hard disk instead.

I've tried Unetbootin but that only copies a few megabytes of files - the rest of the image data in the ISO is ignored.

I have verified the ISO is valid and working with VirtualBox. It's MD5 hash is also as expected. But I need to boot at the real BIOS not an emulated one.

I've also tried things like:

sudo cat /disk/image.iso > /dev/sdb1

and that got "Permission denied" - no idea why.

  • what distro? unetbootin only works on casper based distros...also, what OS do you have running now?
    – Journeyman Geek
    Sep 10, 2011 at 21:03
  • 1
    No guarantees, but you might try using dd instead of cat. Note that it has a special syntax.
    – zpletan
    Sep 10, 2011 at 21:44
  • @Journeyman_Geek The OS in question may or may not have been mystery OS 'X' ;) I'm not sure it's true unetbootin only works on casper based dsitros though Sep 17, 2011 at 21:47
  • @zpletan thanks for the DD reminder, it worked enough, in the end. Sep 17, 2011 at 21:48

5 Answers 5


In the end I used dd and a USB stick as a boot disk because somehow booting didn't seem to work for the dvd on the hard disk.

sudo dd if=/storeM/os-dvd.iso of=/dev/sdb bs=8M

sudo dd if=/storeM/bootdisk.img of=/dev/sdc
  • Has it been working perfectly? Have you found any problems with this approach?
    – Pacerier
    May 3, 2015 at 14:19
  • @Pacerier there are probably problems with this approach but in some scenarios it might be ok. I did it a while ago unfortunately so can't give details. Not hard to test with a small bootable ISO though - maybe Puppy. May 11, 2015 at 23:36
  • Please, let the OS decide how to transfer files efficiently, so use: cat /storeM/os-dvd.iso > /dev/sdb. Even with the best settings, cat is still going to be faster than dd (see this answer). Only use dd if you need more complicated stuff, such as copying only a specific range of bytes.
    – Yeti
    Oct 5, 2018 at 19:44

For information, since this hits a lot of people using sudo while writing to a file. Here's what happens if you use the cat command:

sudo cat /disk/image.iso > /dev/sdb1

is interpreted by the shell as executing sudo cat /disk/image.iso and then sending output to /dev/sdb1. Only the cat command is privileged; the output redirection isn't.

dd avoids these problems since source and target are arguments and part of the privileged command.

  • 1
    Indeed, because redirection is part of the shell. So either you just type su, and then execute the command. Or you use sudo cat /disk/image.iso | sudo tee /dev/sdb >/dev/null. I would really suggest to use cat, because dd can be much slower. Note: when writing an ISO file, usually you want to write to a disk (/dev/sdb) and not a partition (/dev/sdb1).
    – Yeti
    Oct 5, 2018 at 19:57

There is a difference between an ISO image (for cd) and a hard disk image (applicable to usb also). It is however possible to adjust the iso image, so that it fulfil the requirements of a hard disk image. Such an iso image is called hybrid iso. Linux has a tool that does this adjustment: isohybrid.

So here's what I did with success:

cp orig_image.iso hybrid.iso
isohybrid hybrid.iso
dd if=hybrid.iso of=/dev/sdd_ bs=8M

On Debian 8 the utility is contained in package syslinux-utils.


You can use MEMDISK to boot an optical image from a hard drive.

  • And of course the site is currently down... Sep 10, 2011 at 19:22
  • Btw have you tested this to work successfully? I've had very low success rate of getting "boot from file on hard drive" to work.
    – Pacerier
    May 3, 2015 at 14:21

I would consider downloading the file again, also check the integrity, there is a reason you're facing errors. I've never had a problem with UNetBootin.

You can also try Universal USB Installer if you have a Windows system spare. EasyBCD also has an option to insert an ISO to be bootable from the Windows Bootloader, the iso can be executed from memory or the hard disk but is experimental.

  • There is no integrity problem, I validated it's MD5 is as expected. Universal USB Installer didn't work. I will try EasyBCD. Sep 13, 2011 at 5:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .