3

I recently tried to run services.msc and I noticed it had vanished from my hard drive. So I had the great idea of looking up a windows xp cd, booting from it and selecting the "repair existing windows install" option.

Everything was going just fine until I almost hit the end of the progress bar and I got a message box with the message:

"The exception unknown software exception (0xc0000409) occurred in the application at location 0x6976ea96"

After that, I hit OK, and the machine reboots, goes into setup again, gets the same exception, and so on, ad infinitum.

I tried booting with Hirens Boot CD 14.1 and running the Registry Backup & Restore Tool as suggested here, but I got an error, and I doubt it'd have worked since I only have a CCleaner .reg backup from ages ago.

I read somewhere that repair can only be done successfully if you use the exact same cd you used for installing. I'm not sure if I used the same one, and it'd be quite gruesome to look for the one I used for the install.

Any other suggestion?

Update:

  • Checked my motherboard, no apparent physical damage
  • Ran MemTest86+ using Hirens Boot CD. After 4 passes, no errors were found
  • Ran SeaTools from a bootable CD. Both drives passed the Long Test without any errors

So it doesn't seem to be a hardware problem...

10
  • Test your hard drive and memory modules for problems...see post 2 and 3, edit you question to include the results...h30434.www3.hp.com/t5/Notebook-Lockups-Freezes-Hangs/…
    – Moab
    Sep 12, 2011 at 13:27
  • Done, all hardware seems OK. Check my updated answer Sep 12, 2011 at 20:22
  • 1
    What I think happened is you used a XP cd with a lower service pack than what you had installed, now you have a mixed set of system files, I would back up your data and do a clean install of XP.
    – Moab
    Sep 12, 2011 at 20:59
  • So there's no recovering from this? I might find the right CD if I keep searching Sep 13, 2011 at 0:43
  • Doubtful if it repaired using a different service pack than what was installed.
    – Moab
    Sep 13, 2011 at 1:06

2 Answers 2

2

I am guessing that there is a hardware component that is failing. Check for bulging capacitors on the motherboard or other obvious signs of damage internally.

If there isn't any obvious damage you can test the HD with a tool like Drive fitness Test, it will report if the drive has bad sectors.

If the HD passes the fitness test and there are no bad capacitors check for bad RAM with something like Memtest 86.

As for the version of windows, it really just depends on the specific version. For example a home or pro version. It sounds like you have a compatible disk already though if you were able to initialize the repair install.

1
  • It's not a hardware problem, check my updated answer Sep 12, 2011 at 20:23
-1

It was a hard drive failure; I copied most of the failing drive's contents using Clonezilla, and I got my system back up

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.