Here's the situation: laptop is Windows XP SP 3. Wirelss router is Thomson Speedtouch 780WL. I can connect to the internet fine with my laptop using an ethernet cable into the back of the router. My Android smartphone connects fine to the Wifi, but my laptop won't connect to the Wifi. I've tried repairing, disabling and re-enabling the wireless but no joy. This is using the Windows XP wireless client.

I guess, given the fact that my smartphone is working fine, that the problem is with my laptop. Yet, I've connected to hundreds of wifi points before with no problem.

One important factor that I think could be an issue is that recently, while in the UK, I installed one of those 3G USB dongles to use mobile broadband. It was from a company called O2 and it selfishly installed its software (a horrible thing called O2 Connection Manager) which not only managed the 3G connection, but also decided that wasn't enough, that it should also manage my wireless connections. However, it did work fine with any wifi connections I tried, but it seemed to depend on having the dongle plugged in (which I found infuriating). The problem now is that I am no longer in the UK, so I can't use the dongle. Could this be the reason behind my problem? I've no problem uninstalling that O2 software if people think it's the right thing to do.

  • Can you connect to any other Wifi networks now that you don't have the dongle? If not then I'd remove the O2 software as it may be causing the issues you are seeing. – sbtkd85 Sep 12 '11 at 16:55
  • I haven't tried any other networks yet without the dongle. I'll try and do that later this evening but it means a trip on the bus as there is no other wifi around here. – TrojanName Sep 12 '11 at 16:58
  • If you aren't attached to the O2 software, it might just be easier to uninstall that first and see if that fixes your issue. – sbtkd85 Sep 12 '11 at 17:04
  • See if system restore solves your problem. If it does, then it was a driver issue. – soandos Sep 12 '11 at 17:26
  • @sbtkd85 if you turn your comment into an answer, I'll give you the points. Uninstalling the O2 software, then rebooting sorted the problem out. Of course, next time I'm back in the UK without wifi, I'll need to reinstall the stupid thing. That o2 software is one of the worst things I've ever come across. Lots of people on the internet seem to agree with me (for a change)! Thanks – TrojanName Sep 12 '11 at 17:32

If you aren't attached to the O2 software, it might just be easier to uninstall that first and see if that fixes your issue.

|improve this answer|||||

The WiFi radio may be turned off... if it's a laptop you can activate it with "Fn + F6"(there should be a sign for wireless on one of the "F" buttons at least...

I know Dell laptops have a radio that comes with their Dell software that manages the WiFi - is the WiFi card deactivated?

Perhaps you need to configure the router somehow... most often the default IP is

  • Username: admin
  • Password: (blank)

You might be able to get some information here as well.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.