I can't activate Windows 7, I get an error saying DNS name does not exist. Is something configured incorrectly somewhere?

PS: I need the answer within 13 days ;)

UPDATE: I had upgraded from my company's Windows Vista build, and when I connect to the company VPN and activate I get a different error:

The Software Licensing Service reported that the computer could not be activated. No Key Management Service (KMS) could be contacted. Please see the Application Event Log for additional information.

The Application Event Log contains this (I took out the server name, it's one of the company servers):

The client has sent an activation request to the key management service machine. Info: 0xC004F042, 0x00000000, xxxxxxxxxxxxxxxxxxxxxxxxx.com:1688, 7fbdc9b7-d654-49ed-80a7-81a34408f8dc, 2009/09/01 10:59, 0, 2, 17880, ae2ee509-1b34-41c0-acb7-6d4650168915, 25

  • Are you able to visit websites with your browser? – Svish Sep 1 '09 at 10:37
  • Yes, everything works fine, just activation is a problem – Charlie Sep 1 '09 at 10:38

I had this problem too. I simply had to re-input the product key, so give this go.

There is further information on how to do this here if you need it.

  • Thanks, got a new key from MSDN and changed it and it activated fine. – Charlie Sep 1 '09 at 11:26

Problem is in how Windows handle volume licenses.

You can resolve it from command line with:

slmgr /ato 

Detailed description can be found at KB929826

  • A very late +1... this does exactly the same thing as what my answer suggested, just without having to use the silly wizard. I like it... – Kez Jan 18 '10 at 0:12

I solved this problem in a much easier way. Based on some of the comments above, I just connected back to work using my VPN software and everything worked great. If the machine is not connected to the volume license DNS, it will not work.


Sounds like your network settings are broken, or that the Windows activation is not using them correctly.

If you're in Windows now, then it's the latter. Try getting your modem to handle DNS rather than your system.

  • I'm in windows now, and I get the same result when I connect with my 3G card. How do I get my modem to handle dns? – Charlie Sep 1 '09 at 10:00

If I were you I'd set the dns servers on your network adapter to be the opendns ones http://www.opendns.com/ they're far more reliable than most isps. To change them go into you network connections properties then double click on internet protocol v4 change to use these dns settings and fill in the numbers.

  • I've just tried this and still have the problem – Charlie Sep 1 '09 at 10:44
  • I suppose there's an outside chance the activation servers are down. – Col Sep 1 '09 at 12:24

double check your system date/time. I was banging my head off the wall until I realized that was the issue.



if you want to activate now, choose the option "activate by telephone" and Windows should provide you both a pay/premium number and a toll-free/freephone number.

Personally, it is a bit slower but I prefer this method. It is quite fast.

DNS is what resolves host names (friendly .com or other TLD's) in to the computer IP address.

You are having problems finding out what the Microft Activation addresses are.

I am guessing you have general problems whilst browsing the internet.

If I was you post another question about your problems and I am sure someone will help you.

  • Having no problems browsing web at all, and the "show me other ways to activate" option is greyed out :( – Charlie Sep 1 '09 at 11:03
  • Ouch :S well, you stumped me :S Seen the accepted answer and that is just weird if you were getting DNS issues rather than just invalid licence. – William Hilsum Sep 1 '09 at 11:29
  • The install was set for KMS meaning the company has to have a KMS server setup for the client to activate against... apparently they didn't, or it wasn't lookup:able, and changing the key to a MAK version then sorted it out because MAK is activated against Microsofts servers instead – Oskar Duveborn Sep 1 '09 at 11:48
  • ahhh, so internal dns issue... Ok, I understand! Thanks, – William Hilsum Sep 1 '09 at 12:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.