I am having trouble with my Macbook Pro (late 2008, OS X 10.5) at boot.

Here is an outline of my problems and attempted solutions:

  1. As the computer was going to sleep it got stuck such that when I tried waking it up, I got a black screen with the mouse cursor.
  2. I tried opening and closing the lid of the MBP to get it to sleep but that did not change the state.
  3. I did a hard shutdown and then tried flashing the p-RAM.
  4. I booted into verbose safe mode (shift-cmd-v) and after about 45 minutes I am stuck with repeating messages that look like this:


disk0s2: I/O error.
HFS resolvelink: can't find iNode79913
disk0s2: I/O error.
HFS resolvelink: can't find iNode80152

This error message is mixed in with other more typical boot messages: Auth result for : <MAC-ADDRESS> MAC AUTH succeeded.

Also - although there was an initially large number of iNodes failing, it is now restricted to 3 specific numbers which repeat over and over again.

My next option is likely to try booting from the install disk to try repairing the disk with disk utility, and then trying single user mode to try fsck -fy.

  • Are there any other options out there?

  • How long should I reasonably let this continuing safe mode boot run before moving onto the next option?

  • Any particular reason you don't just do it? Also, you could try to read the SMART information from Disk Utility when booting from disk. It's quite condensed but still might be able to tell you whether your hard disk has issues or you just need to vacuum your file system. – Daniel Beck Sep 13 '11 at 18:38
  • @Daniel Beck - I've never seen this particular issue before and would like to use the least aggressive approach first. I reckon that disk utility isn't likely to be a problem, but fsck could cause further difficulties. – dtlussier Sep 13 '11 at 18:44
  • fsck -fn perhaps? – Daniel Beck Sep 13 '11 at 19:00
  • 3
    I hate to sound like a pessimist, but once you start seeing these kinds of errors, you have to realize that there is a cause - which is either a software event that caused things to become corrupted (possible but no the highest likelyhood) or a hardware failure of the disk. I think that this point, the best thing to do is to get a replacement hard drive to get the system working again, then then see what you can do to recover important data from the drive. Trying to use any disk utility tools to recover the drive as a boot drive will quite likely result in definite lost of data later on. – Zeke Hansell Sep 13 '11 at 19:04
  • @Zeke - yeah I hear you. I was fearing I was at that point too. I'm going to take your advice and just replace the HD before doing anything rash. Thanks. – dtlussier Sep 13 '11 at 19:07

In the end I'm going to answer my own question here to close up the thread.

In the end I went through the following steps:

  • DiskUtility: First Aid sweeps.
  • Boot into single user mode: Ran fsck -fn.
  • Boot into safe mode: Also tried fsck -fn.

None of these produced good results. DiskUtility couldn't complete its FirstAid sweeps, and fsck kept producing:

disk0s2: I/O error.
HFS resolvelink: can't find iNode79913
disk0s2: I/O error.
HFS resolvelink: can't find iNode80152

At this point I thought I would try formatting and re-installing as i THOUGHT I was fully backed up. HOWEVER, due to the failing disk there appeared to be a problem with the disk/OS X systems which my backup system (Crashplan, although that should be the topic of another superuser question) uses to detect new files. Therefore, my backup was about 2.5 weeks out of data which led me to concede that the hardware was failing and to try some data recovery on the failing disk via:

  • DiskWarrior
  • DataRescue3

Neither of these methods produced very useful results:

  • I could not boot into either DiskWarrior or DataRescue3, so instead I tried to use them on the failing disk by mounting it as a firewire drive (target disk mode) from another Mac.

  • In target disk mode I had the following results:

    • Could not access any significant amount of data from the Finder or the Terminal. When I tried to read larger files the process would eventually get stuck with either the spinning beachball or simply stop responding.
    • DataRescue3 initially made some progress reading the disk, but would consistently through up Long read errors.
    • Although the failing disk would mount, as I tried to access it more and more copies of the disk would mount and appear in the Finder. As a new copy of the disk mounted in the Finder the previous one would become inactive.
  • In the end I achieved some success in recovering the most important missing files by targeting my efforts at the files and folders which I knew I absolutely needed. In addition to manually attempting this from the Finder, I used a Python script to walk the file tree looking for new files to copy.

  • These recovered files were then merged with my old Crashplan backup to produce a reasonably good backup.

  • Having recovered the files Apple replaced the drive as I was still under AppleCare warrantee at the time.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.