I've got an Intel-based MBP with Lion and figured for the heck of it I'd try to boot camp the Windows 8 developer preview. It was my first time fooling with boot camp and everything worked until I got to the installer. I had a DVD for Win8 and burned the boot camp drivers onto a CD. Everthing went fine until the second screen of the install; Windows told me it couldn't find any drivers for my CD drive. I figured they might be on the driver CD, and the Windows installer noted it expected me to eject the install CD anyway.

Except since the boot camp drivers weren't installed, the eject key for the optical drive doesn't work. So I sighed and rebooted. Now I can't boot into Mac OS because it expects to boot from the drive. Holding option during reboot lets me pick the right hard drive, but it's stuck in a boot camp loop and won't do anything but complain there's no bootable media. Yikes. So I'm restoring Lion and that may or may not work, I'm sure eventually I'll talk the machine into booting again.

Since I'm dumb, I'm going to try again later. Maybe putting the drivers on a USB drive, or using a bootable Win8 USB drive will work? Maybe someone can teach me some voodoo to eject the disc? Would it have been so much trouble to let the drive have a hardware eject button?

  • Hold down the track pad button when booting to eject the disk. – user97903 Sep 15 '11 at 3:33
  • 1
    or do the intelligent thing, pick up VMWare Fusion or VirtualBox and use the awesome power of your laptop to run the dev preview INSIDE OSX. (once you follow Felix's advice to get the disk ejected...) – peelman Sep 15 '11 at 3:52
  • That doesn't really help me install Windows 8 though. – OwenP Sep 15 '11 at 3:53
  • @peelman: I tried using your webRDP program, but I could not get it to work superuser.com/q/335894/8972 – paradroid Sep 15 '11 at 10:35
  • @peelman Yes, it's the "intelligent" thing. No one should ever have any desire to run an OS on bare metal. I've run VirtualBox for Win7 and it spins my fans and eats my battery more than I'd like; doesn't happen if I boot directly to Windows. – OwenP Sep 15 '11 at 12:29

It might not be the same problem, but I got the CD Drive driver message too. In my case it was because file download was incomplete (which I hadn't noticed) my ISO burner didn't complain so the required files were simply missing. The size of the files that eventually worked for me:

5,197,092,864 WindowsDeveloperPreview-64bit-English-Developer.iso
3,905,548,288 WindowsDeveloperPreview-64bit-English.iso
  • Interesting... I've got the developer one and it's only 2.1GB. I'll re-download and try again. – OwenP Sep 15 '11 at 12:27

I'm not really sure its wise to assume that there will be Bootcamp-compatible drivers for your machine for a competing OS beta. Especially not when Apple is still working on the tweaks to Lion. There are two things you might try:

  1. Abandoning BootCamp. It's a utility that helps you walk through the "partition and install a new OS" system, but it's not exactly necessary. Though that will still leave you driverless. Perhaps pick up a cheap external keyboard and mouse with an eject key that Windows 8 might have drivers for?
  2. Virtual machines. Seriously, installing wacky developer previews is essentially what a virtual machine environment is best at. When all else fails, rather than your nice MBP having hardware quirks, you just delete the thing and start again. Also, you don't have to tangle with drivers that may not be there. I understand the desire to do some on-machine testing, but its a little premature for Windows 8 running on Apple hardware.

I think you may have more success using rEFit. It's an EFI based boot menu that can boot mac, Linux and windows.


For me this worked well where bootcamp didn't work so well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.